Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is very strange issue. I'm on Windows XP. I have tried to put

into C:\WINDOWS\system32\drivers\etc/hosts. When I tried to save the file, it said me I do not have enough permissions (I'm admin). So I have just deleted the hosts file and saved the one I wanted. Suddenly, when I go to, Facebook login screen appears. When I try to


I get (translated following text from Czech)

Command PING to [] with 32 bytes length:

Response from bajts=32 time=66ms TTL=53
Response from bajts=32 time=81ms TTL=53
Response from bajts=32 time=114ms TTL=53
Response from bajts=32 time=123ms TTL=53

(I have real IP instead of, but I don't want to share it here)

Even worse thing is, that when I try to go to, I get connection error (Because it's problably trying to connect the server specified, which doen't have the https supported

Why is this happening? Is there some specific reason why is it still connecting to facebook?

Additionally, I have tried to / I know that

  • flush DNS with cmd
  • checked if I'm not using browser's proxy (no, I'm not)
  • connect to - it fails, it means that the real Facebook server isn't reached when using https
  • AVG has expired lincense, therefore it shouldn't act on my PC anymore
  • that the same problem happens on IE and on Firefox, too
share|improve this question
The obvious, have you cleared the DNS resolver cache? ipconfig /flushdns – Sathya Nov 24 '11 at 13:38
Does the '' IP address exist locally? – HaydnWVN Nov 24 '11 at 13:38
@Sathya: yeah, + restarted Firefox – genesis Nov 24 '11 at 13:54
@HaydnWVN: no, I don't want to share the real IP - (I have real IP instead of, but I don't want to share it here) – genesis Nov 24 '11 at 13:55
Is this question a dupe of: – Ivo Flipse Nov 24 '11 at 15:52

1 Answer 1

Firefox has a built-in DNS cache.

To clear it, you can use the add-on clear dns cache.

share|improve this answer
I have tried it with IE, with no effect – genesis Nov 24 '11 at 14:35
Are you using a router or a proxy server? Both might be caching DNS entries. – Dennis Nov 25 '11 at 13:02
as I have hosts file in place, with IP, I assume it should not request DNS. – genesis Nov 25 '11 at 13:25
If works but does not, it is clearly a caching issue. – Dennis Nov 25 '11 at 13:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.