Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to use PsExec from a server to run GUI applications on remote Windows 7 machines on our domain:

psexec //remoteMachine -i kioskApp.exe

The above is run by an admin user.

What we're trying to do is every so often force all employee PC's to run an app the puts them into kiosk mode and forces them to fill in certain information. (It's a company policy thing - if not for the enforcement, employees would simply neglect filling in the info.)

Problem is, it will appear on the remote machine, but everything within the frame will appear entirely black.

If I use -i 0 instead of just -i, the users are given the option to choose whether to let the app run, which defeats the entire purpose of running the app in the fist place!

Help would be greatly appreciated! Thanks in advance!

share|improve this question
add comment

3 Answers

Try to use the -s switch, it worked for me.

psexec //remoteMachine -s -i kioskApp.exe

The -s switch is for ruuning the process as SYSTEM user, so I know it could be weird to combine those parameters, but it works!

share|improve this answer
    
I had been running into Jacob Spire's issue. All I wanted was to display a text file on a user's screen, just to make sure I had the parameters correct. To display a text file on a Windows PC: psexec \\PcName -s -h -i 1 notepad.exe c:\hello.txt –  Bad Neighbor Sep 24 '13 at 17:31
add comment

Have you thought of setting up a scheduled task to run the program? You can use the "BUILTIN\Users" User when you create the task to have it run as the logged on user. Doing it this way would allow you to use group policy to send it out instead of depending an admin computer launching the program.

I'll warn you now that it will take some time and testing to get setup, but it is extremely powerful. I'd only try it if you can't get PSexec to work.

share|improve this answer
add comment

Be sure to set the -u and -p for domain\user and password on the remote PC. I was having the same issue and figured out that setting the user corrected the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.