Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I set Crashplan to back up my data to my external hard-drive, which was listed as G:/ at the time. Unfortunately, the computer would assign that letter to whatever drive was connected first on any given day, so occasionally the USB drive would end up being G:/, and Crashplan would try and use it as a backup location until it filled up completely.

I tried to be clever and get around this issue by assigning the letter Z:/ to the hard-drive, and telling Crashplan to back up there instead. This worked fine at first - Crashplan resynced, and I could back up to and restore data from the drive.

Unfortunately, something isn't working anymore. Crashplan keeps telling me that the backup location is unavailable, despite the fact that the hd is plugged in, Crashplan is set to backup to the correct folder ( Z > 489443350473650708) and I can open the folder just fine, so I don't think it's the hd that's the problem.

I really need the data from the hd. What could be the problem, and how can I fix it?

I've tried assigning G to the hd again and telling Crashplan to go to G > 489443350473650708 instead, but that didn't work, either, it still tells me the backup location is unavailable.

share|improve this question
I have the same problem. I am wishing there was a way to bind CrashPlan to the Volume GUID instead of a drive letter. – zacharydl Mar 30 '13 at 17:11

I don't know which Operating System you're using, but all versions have a my.service.xml configuration file! The file is located in the conf/ directory, where you've installed Crashplan.

You have to stop the CrashPlanEngine first, in order to edit the service file. On Linux, you can use ./bin/CrashPlanEngine stop to stop it, on Windows, I guess, you can use the Services-List to stop the Crashplan service (you can also try to edit the file, and then reboot your computer)

Another good resource for help are the various log-files in the log/ directory of your installation.

I would recommend you to set the backup path manually in the configuration file!

I hope this helps you to find a solution.

share|improve this answer
If somebody is talking about G and Z for drive stations, that can only mean it's Windows! – SPRBRN Jul 29 '14 at 7:50
You are right. Looks like I did not read the question closely enough. – rmetzger Jul 29 '14 at 11:24
Sorry for picking up such an old question! I didn't notice the date. – SPRBRN Jul 29 '14 at 11:43

Are you connected to the internet with the computer? CP needs an internet connection to work, even for local backups. This is a serious flaw, and it will make your backup worthless if the CP site goes offline or bankrupt. Despite all this I still think CP is one of the best backup services, and I use it myself.

Some advice for the future...

Always use a second backup method, like the standard Windows backup.

If you experience problems with a backup, don't trust it before you tested it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .