Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i copied some arabic subtitle files from a friend and when trying to view them on windows 7 home premium with notepad the texts appears as follows:

ÃíåÇ ÇáÓÇÏÉ ÃäÇ ÇáÂä Úáì æÔß ÅÑÓÇá ÅÔÇÑÉ
ãä åÐÇ ÇáßãÈíæÊÑ ÇáãÍãæá ÚÈÑ ãÒæÏ ÎÏãÉ ÇáÅäÊÑäÊ

as a quick workaround, i open the file with microsoft word, and choose the encoding Arabic (Windows) , so the text will appear correctly, then i copy the text, and paste it in the srt file, and save the file as UTF-8

but i was looking if there's another good solution to avoid such problem. please advise.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

The software that loads the subtitle normally have a way for you to choose the encoding.

In DirectVobSub it's on the very first tab as a drop-down. In MPC(-HC), it's a similar drop-down in the default subtitle style page in options.

share|improve this answer
add comment
  1. download Notepad++
  2. open the notepad document using notepad++
  3. menu bar , click encoding , then character sets,arabic, windows 1256
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.