Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to disable my LAN from command prompt. For that, I have tried the command netsh interface set interface Local Area Connection DISABLED. I get an error saying:

Area is not an acceptable value for admin.
The parameter is incorrect. 

What am I doing wrong? I have admin rights and am on a 64 bit OS.

share|improve this question

migrated from programmers.stackexchange.com Nov 25 '11 at 13:27

This question came from our site for professional programmers interested in conceptual questions about software development.

add comment

2 Answers

up vote 2 down vote accepted

Wild guess, quotes around multi word arguments:

netsh interface set interface "Local Area Connection" DISABLED
share|improve this answer
    
thanks for the help. it worked. –  CyprUS Nov 25 '11 at 13:21
1  
@CyprUS if it worked you should check the checkmark under the vote button and give Thorbjorn the credit for giving the correct answer. –  Scott Chamberlain Nov 25 '11 at 20:59
    
It doesn't work on Win XP SP3. See my answer. –  Massimo Mar 12 '13 at 12:26
    
@Massimo it doesn't? Really. Why not? (and your answer isn't) –  Thorbjørn Ravn Andersen Mar 12 '13 at 12:44
add comment

Windows XP SP3, italian

C:\>netsh interface show interface

Stato admin    Stato          Tipo             Nome interfaccia
-------------------------------------------------------------------------
Abilitato                     Dedicato         Connessione alla rete locale (LAN)
Abilitato                     Interna          Interno
Abilitato                     Loopback         Loopback


C:\>netsh interface set interface name="Connessione alla rete locale (LAN)" admin=DISABLED

Uno o più parametri essenziali non sono stati specificati
Sintassi non valida. Consultare la guida per la sintassi corretta per il comando

Translation :

One or more missing parameters. Syntax Error ...

The same error using

C:\>netsh interface set interface "Connessione alla rete locale (LAN)" DISABLED
share|improve this answer
    
Sorry I use the answer ( THIS ISN'T A ANSWER ) but in a comment I cannot include my tests with the right formatting. –  Massimo Mar 12 '13 at 14:17
    
it's probably because the accepted answer was aimed at a more recent windows version. –  Ярослав Рахматуллин Mar 13 '13 at 10:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.