Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed ImageMagick through, (Using ImageMagick 6.7.3-7)

./configure --prefix=/usr && make && make install

When I try to

gem install imagemagick

I get

Building native extensions.  This could take a while...
ERROR:  Error installing rmagick:
    ERROR: Failed to build gem native extension.

/usr/bin/ruby extconf.rb
checking for Ruby version >= 1.8.5... yes
checking for gcc... yes
checking for Magick-config... yes
checking for ImageMagick version >= 6.4.9... yes
checking for HDRI disabled version of ImageMagick... yes
Package MagickCore was not found in the pkg-config search path.
Perhaps you should add the directory containing `MagickCore.pc'
to the PKG_CONFIG_PATH environment variable
No package 'MagickCore' found
Package MagickCore was not found in the pkg-config search path.
Perhaps you should add the directory containing `MagickCore.pc'
to the PKG_CONFIG_PATH environment variable
No package 'MagickCore' found
Package MagickCore was not found in the pkg-config search path.
Perhaps you should add the directory containing `MagickCore.pc'
to the PKG_CONFIG_PATH environment variable
No package 'MagickCore' found
Package MagickCore was not found in the pkg-config search path.
Perhaps you should add the directory containing `MagickCore.pc'
to the PKG_CONFIG_PATH environment variable
No package 'MagickCore' found
checking for stdint.h... yes
checking for sys/types.h... yes
checking for wand/MagickWand.h... no

Can't install RMagick 2.13.1. Can't find MagickWand.h.
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/usr/bin/ruby

This is despite the fact that MagickWand.h is already in the system in /usr/include/ImageMagick/wand/MagickWand.h. So the question is, how do I actually get the compiler to look in there?

share|improve this question
add comment

8 Answers

Had the same problem on CentOS using latest everything (as of Dec 2011), and fixed it with:

export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig"

in my .bashrc file to pick up MagickCore.pc, then created two symlinks:

ln -s /usr/local/include/ImageMagick/wand /usr/local/include/wand
ln -s /usr/local/include/ImageMagick/magick /usr/local/include/magick

And voila, the MagickWand.h was found, the MagickCore.pc was picked up... gem installed successfully.

I imagine another solution would be to modify the configure options set during ImageMagick installation, but I'm not enough of a sysadmin to be clear what the right option and location would be for these files. After 45 minutes of googling around, I couldn't figure where these files are supposed to live, to be automatically picked up by the gem install make system.

Cheers!

share|improve this answer
    
I was having the same issue on RedHat 6 and your solution worked for me. Thanks a bunch! –  Callmeed Mar 5 '12 at 18:56
    
Thanks! This works for me!!! /o/ –  Kleber S. Mar 12 '12 at 7:20
1  
+1 The export statement alone fixed it for me. –  Kelvin Mar 30 '12 at 19:54
    
Awesome, this even worked like a charm in mountain lion! I need to run all the statement above for rmagick gem to be installed. –  Hendra Uzia Sep 3 '12 at 5:08
    
Tried this and got "/usr/local/bin/Magick-config: line 41: pkg-config: command not found /usr/local/bin/Magick-config: line 47: pkg-config: command not found /usr/local/bin/Magick-config: line 50: pkg-config: command not found /usr/local/bin/Magick-config: line 53: pkg-config: command not found" –  Jonny Apr 18 '13 at 10:33
add comment

ImageMagick will typically put MagickCore here:

/usr/local/lib/pkgconfig/MagickCore.pc

If yours isn't there, you can find it like this:

find / -name MagickCore.pc

You now know your pkgconfig path:

/usr/local/lib/pkgconfig

Set the environment when you install the gem:

PKG_CONFIG_PATH=/usr/local/lib/pkgconfig gem install rmagick
share|improve this answer
    
Thanks! Worked for me on a Bitnami Ubuntu 12.04 image.. –  JD. Jun 1 '12 at 3:14
add comment

The key is in the configure output where it says "checking for wand/MagickWand.h" - clearly the ImageMagick directory is not expected in /usr/include, which means you need to either move the contents of that directory up a level or you need to install ImageMagick itself differently. Putting stuff directly in /usr is generally a bad idea for anything not provided by the system itself - if you segregate all of the things you add in /usr/local instead and leave /usr largely alone, you'll find the system much easier to administer as well since you'll be able to (long after you've forgotten about this) figure out what you added vs what came with the system.

share|improve this answer
    
Good advice, although you still have not answered the question how you can force the compiler to look in certain directories for the header file. –  Ken Li Nov 25 '11 at 18:13
3  
Well, the compiler invocations are all happening through the gem command (you force the compiler to look in alternate locations with the -I flag, but this user is not using the compiler directly) and its best to set things up with the configure command such that goodness occurs without having to alter anything else. Using the PKG_CONFIG_PATH env variable that configure keeps screeching about may do the trick if there is a MagickCore.pc file available. "find /usr -name MagickCore.pc" and then see if it exists, then add the dir it's in with "setenv PKG_CONFIG_PATH /path/to/where/find/found/it" –  jkh Nov 25 '11 at 18:21
    
I updated PKG_CONFIG_PATH to /Dir/to/where/found/MagickCore.pc and still end up with "Can't install RMagick 2.13.1. Can't find MagickWand.h" .. any suggestions why it might not be picked up and what else I can try .. Not sure how to use the -l option ? –  p101 Mar 2 '12 at 19:31
    
Hmmmm! That should have worked. Question: If you type ./configure --help, does it list any configure options for ImageMagick specifically? If so, you may be able to point directly at the ImageMagick directory in /usr/local from the configure script. –  jkh Mar 2 '12 at 20:19
    
Thnx jkh.. Interestingly I didnt find configure in rmagick, so probably you mean imagemagick. I have created a new question here stackoverflow.com/questions/9561386/rmagick-installation . Would appreciate if you can take a look . Thanks! –  p101 Mar 5 '12 at 3:46
add comment

You may want to install the appropriate support package for your distribution: http://rpmfind.net/linux/rpm2html/search.php?query=pkgconfig%28MagickCore%29

Had exact same issue on CentOS, rmagick installed fine after yum install ImageMagick-devel

share|improve this answer
add comment

For CentOS, I solved this issue by installing the "ImageMagick-devel" package:

yum install ImageMagick-devel

share|improve this answer
add comment
        1) install by installer

http://cactuslab.com/imagemagick/

2) try gem install rmagick

if checking for wand/MagickWand.h... no
type

mdfind MagickWand.h

find some thing like

/Users/user/ImageMagick-6.8.3/include/ImageMagick-6/wand/MagickWand.h

and type in terminal

C_INCLUDE_PATH=/Users/user/ImageMagick-6.8.3/include/ImageMagick-6/ gem install rmagick

if, after that you have this error (because a had it) "Package MagickCore was not found in the pkg-config search path."

type

mdfind MagickCore.pc

find some thing like /opt/ImageMagick/lib/pkgconfig/MagickCore.pc

and finally in terminal type:

PKG_CONFIG_PATH=/opt/ImageMagick/lib/pkgconfig/ gem install rmagick
share|improve this answer
1  
The command mdfind is a MacOSX only command, it doesn't exist on Linux variants. –  slm Mar 28 '13 at 12:50
    
as @slm said, please re-write your answer so it helps the QA. –  Lorenzo Von Matterhorn Mar 28 '13 at 12:54
add comment

I was installing redmine under Mac OS X mountain lion...

The installer failed on rmagick...

After lots of troubles, it worked by installing "homebrew", but NOT installing rmagick through homebrew. Instead I installed "pkg-config" through homebrew, because rmagick was complaining about that.

The commands:

ruby -e "$(curl -fsSL https://raw.github.com/mxcl/homebrew/go)"
brew doctor
brew install pkg-config
sudo gem install rmagick

Then redmine went on installing with no problems.

share|improve this answer
add comment

This solved the problem for me. Apparently the latest version that comes with homebrew doesn't work well with the gem.

http://blog.paulopoiati.com/2013/01/28/installing-rmagick-in-mac-os-x-mountain-lion-with-homebrew/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.