Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This has happened for me as long as I can remember. Since the first version of Firefox, on multiple computers and under different versions of Windows. QuickTime plays fine in IE and Chrome (even with Firefox in the background), but in Firefox if my mouse is not over the QuickTime window then it will start to studder, then lag and eventually just stop.

  • To be honest, I do keep quite a few tabs open, but Firefox stays at 1% CPU (even when QuickTime runs) and I have a few gigs of free RAM.
  • It is the same for any resolution of video or audio.
  • If the mouse is just one pixel in the client area of the QuickTime then it usually plays fine.
  • Other video formats typically play fine.

Does anyone else notice this behavior? Ultimately I would like a fix besides keeping my mouse over the QuickTime window.

share|improve this question
add comment

1 Answer

Most video lag in Firefox is caused by the session saving feature. Here is the fix (which will work for YouTube, Hulu and other embedded video playback).

  1. Open Firefox and in the Location/Address Bar type in about:config and hit Enter.
  2. You are now looking at some of the advanced functions that can be customized.
  3. In the “Filter” line at the top of the list (where your cursor should already be blinking) type in session and it will automatically reduce the listings.
  4. Now find “browser.sessionstore.interval” and double click it. That number is how many milliseconds between the times that Firefox saves your current browsing session in case of a crash and 10000 milliseconds equals 10 seconds – the same amount of time between video freezes.
  5. Change that number to something different. 300000 is 5 minutes and 120000 is 2 minutes. I actually switched mine to 600000, which is 10 minutes, because I don’t worry about session saving much.

Hopefully that will help!

share|improve this answer
    
Does that require a restart to take effect? I don't have lag in any other video, but I will give it a shot. –  Jim McKeeth Sep 5 '09 at 8:11
    
I restarted just to be sure and it didn't improve things any. Thanks though. –  Jim McKeeth Sep 5 '09 at 8:26
    
It was worth a shot anyways. Changing that setting helped with most of the embeded video lag I was getting in Firefox previously. Please post back if you find a solution outside of Super User - I'd be interested to know. –  Insomnic Sep 5 '09 at 17:07
    
I still haven't gotten it working. I take it it works fine for you? –  Jim McKeeth Oct 5 '09 at 3:38
    
I don't typically have any trouble with Quicktime in Firefox. I don't access a lot of embedded Quicktime videos though - I typically choose higher res versions which normally play in the player instead of embedded. You could try removing Quicktime and using Quicktime Alternative (bit.ly/xxlSu) instead. –  Insomnic Oct 5 '09 at 15:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.