Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I plug in an LCD LG monitor via VGA to my notebook while running X it never gets detected.

As a matter of a fact there are only two scenarios that occur:

  1. X server is started with monitor already plugged in: xrandr shows one display with resolution equal to the sum of both displays (something like 3000x1080), however, I can use the monitor at will,

  2. X server is started without monitor plugged in: xrandr shows only my notebook display (1280x900) and the appropriate resolution.

Even though I can use the monitor at this very moment, it requires X restart in order to start with new resolution. What is more in both cases the monitor is never shown as a another display/screen in xrandr, it only makes the only display entry resolution in xrandr bigger. That might not be that serious, but whenever I want to use the monitor after I have started X - it doesn't even get detected.

From what I can gather that is a problem of NVIDIA drivers and me using NVIDIA's TwinView, as you can see in the attached xorg.conf.

Do you think the problem could be resolved while using NVIDIA drivers or is it a complication due to the usage of TwinView?

I am running Gentoo Linux, tuxonice-sources package version 2.6.38-tuxonice-r2

share|improve this question
    
Solved, see above. –  Chester K Nov 25 '11 at 20:25
    
@slhck: Oh, right. I am sorry for that. I have tried to make a new post, however, because of my beginner status here on this server I cannot post a reply for another few hours, by editing the post I was hoping to avoid unnecessary replies. I shall wait the time alloted then. –  Chester K Nov 25 '11 at 20:35
add comment

2 Answers

up vote 1 down vote accepted

From Linux: Setting primary display (nvidia) form command line

I used the disper 0.3.0 package (homepage) and then used

./disper.py -d DFP-0,CRT-0 -r auto -e -t right

and the result was exactly as required.

share|improve this answer
add comment

Whenever I plug in an LCD LG monitor via VGA to my notebook while running X it never gets detected.

if it is plugged, enter

$ xranddr

It will list out the connected/disconnected outputs:

Screen 0: minimum 320 x 200, current 2340 x 1440, maximum 8192 x 8192
LVDS-1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 303mm x 190mm
   1440x900       60.0*+   50.0  
   1152x864       60.0  
   1024x768       59.9  
   800x600        59.9  
   640x480        59.4  
   720x400        59.6  
   640x400        60.0  
   640x350        59.8  
VGA-1 connected 900x1440+1440+0 left (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900       59.9*+   75.0  
   1280x1024      76.0     75.0     72.0     60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
   640x350        70.1  
DVI-D-1 disconnected (normal left inverted right x axis y axis)
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.