Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm encountering issues installing Windows alongside my Lion install. I'm attempting to install from the internal SuperDrive, after using Boot Camp to partition what was a single, HFS+ volume.

  1. When holding down Option at boot, the CD appears in the startup list, but upon selecting it, I get a gray screen for 5 minutes, then a flashing white folder.

  2. I tried installing rEFIt and using this to boot the CD, but I receive an error about "Not Found" being returned from the "LocateDevicePath", and a mention of the firmware not supporting booting using legacy methods.

  3. In the Console, when opening the StartupDisk preference pane (which never presents the CD as a selectable option), I see:

    11/25/11 4:39:31.159 PM System Preferences: isCDROM: 0 isDVDROM:1

    11/25/11 4:39:31.159 PM System Preferences: mountable disk appeared: /Volumes/GRMCPRFRER_EN_DVD

    11/25/11 4:39:33.214 PM System Preferences: -> So far so good, passing disk to System Searcher.

    11/25/11 4:39:33.218 PM System Preferences: OSXCheck: No boot.efi in System Folder or volume root.

    11/25/11 4:39:33.220 PM System Preferences: WinCheck: Not a valid windows filesystem: /Volumes/GRMCPRFRER_EN_DVD

    11/25/11 4:39:33.220 PM System Preferences: WinCheck: Not a valid windows filesystem: /Volumes/GRMCPRFRER_EN_DVD

I'm at a loss here. I've done my research, but it sounds like most of the rEFIt errors of this nature are caused by installing from a thumbdrive, or an external drive. I'm using the internal SuperDrive.

Also, I've tried this with two different disks:

  1. A Windows XP SP2 CD
  2. A Windows 7 x86 DVD

Both are disks I've had around for years, and I've used them reliably in the past. The system is an early 2011 15" Macbook Pro, all firmware updates installed.

share|improve this question
    
For some reason, those ROM discs are not being seen as bootable. That's my take. –  user3463 Nov 25 '11 at 22:08
    
Right, but I'm trying to figure out why. They boot fine on a few other PCs I have lying around, and I've used them to install Windows in the past on other Boot Camp'ed Macs that I no longer own. I'm convinced it's a hardware/software issue with this machine, but I'm trying to determine what the problem is. –  Craig Otis Nov 25 '11 at 22:26
1  
I'd go with hardware / firmware, myself. Too often I've seen perfectly usable discs that Just Don't Work. The easiest way to confirm this is with an external ROM drive. –  user3463 Nov 25 '11 at 22:27
    
I have the newest firmware installed as per Apple's doc: support.apple.com/kb/HT1237 I just double-checked both disks on my Desktop PC, and they are indeed both bootable. I just wish I knew what the issue was with the Macbook. –  Craig Otis Nov 25 '11 at 22:43
    
I'm wondering if this is a 32-bit issue. Both the XP and Windows 7 disks are x86, and I think this model machine might only support 64-bit versions of Windows. –  Craig Otis Nov 25 '11 at 23:19

2 Answers 2

You can always start the installation process in a virtual machine and reboot the host to complete it. Here's how

  1. Get a virtual machine software that can use the boot camp partition directly. Parallel Desktop, VMware Fusion and Virtualbox can all do this. (The trial versions should be enough for this.)
  2. Setup a virtual machine with 2 CD-ROMs and uses the boot camp partition as disk.
  3. Get a bootable Windows PE cd image. (If you don't want to use one, you can use the Windows 7 installation disk and press SHIFT+F10 after it's fully loaded to get a command prompt.)
  4. Once your PE system is loaded, insert your Windows CD and mount it to the other virtual CD drive of the VM.
  5. Run the setup.exe program as usual but remember to choose custom/new install. For pre-Vista versions, you have an option behind one of the buttons to copy all the files to disk. You must select that. This is done automatically for you since Vista.
  6. Shutdown your VM when the installer reboots your system for the first time. If you missed this, you must go back to step 4 and try again because after the reboot Windows may start to detect your hardware environment and install drivers.
  7. Reboot your system to the boot camp partition and finish the rest of the installation process.
share|improve this answer
up vote 1 down vote accepted

Yikes, have confirmed this to be an incompatibility with the Intel-branded SSD drives in early 2011 (and maybe other) MacBook Pros.

I had an appointment at the Apple store today, scheduled a repair, and was told to replace the SSD that I had installed (80GB X25-M) with the original Apple drive before sending it in. I swapped out the drives, decided to try booting one last time, and sure enough, worked just fine.

With this extra info, I stumbled upon this thread, which indicates it affects the X25 and 320 drives, when used with the early 2011 MBPs. (The later 2011 models seem to have firmware improvements that alleviate this issue.)

MacRumors Thread

share|improve this answer
1  
That's unfortunate. Good info to know. Is it just an issue with booting off the disk? Check out Bill's answer above, you might be able to jump-start the installation without having to boot off the DVD. –  nhinkle Nov 26 '11 at 20:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.