Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to get .htaccess to work under Apache, but the server doesn't seem to honor it.

In httpd.conf I have:

AllowOverride All

I have restarted the server with service httpd restart. I have also done a service httpd reload.

The docs suggest testing the configuration with a garbage .htaccess file. If the server succesfully reads the garbage .htaccess file, this should result in an error when retrieving a page from the directory. But I get no error, suggesting that the server is not parsing the file.

What might be wrong?

share|improve this question
up vote 0 down vote accepted

Start here. Within <VirtualHost 123.456.7.89>, you need to have the following:

<Directory "/host/domains/www.foobar.com">
Options All MultiViews
AllowOverride All
# or AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>

Source: http://forums.devshed.com/apache-development-15/htaccess-not-being-accessed-8977.html

share|improve this answer
1  
This wasn't exactly it, but I realized there was more than one 'AllowOverride' setting in httpd.conf. Fixing both did the trick. – Anders Feder Nov 25 '11 at 23:51
    
Glad I could help then! – user3463 Nov 26 '11 at 3:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .