Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to get metacity to work on my #! installation, but instead when I try to run metacity at the command line, it tells me that there is another WM in process.

I then tried to run metacity --replace (as it suggested) but to no avail; it appears as though X quit.

What should I do? Or how can I get CrunchBang to otherwise look a bit more like Ubuntu?

share|improve this question

I have experience metacity causing X to quit when I was running live session. When I've installed crunchbang, it worked perfectly fine (I was using xfce4 though):

sudo apt-get install xfce4 metacity metacity-themes

After then either logout, and select xfce4 for your session, or use:

xfce4-session
metacity --replace

You can then use xfce4 configurations to set different theme, - however to change metacity themes, you'll have to install gconf-editor:

sudo apt-get install gconf-editor

Run it:

gconf-editor

And go to apps/metacity/, and change the theme name.

You can find metacity themes here: http://gnome-look.org/index.php?xcontentmode=101

After downloading it, put it to the ~./themes directory.

share|improve this answer
    
Thanks! "Crushing X"? – tekknolagi Nov 26 '12 at 15:18
    
Basically it kicked me back to the GDM. ;) – VxMxPx Nov 26 '12 at 22:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .