Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I limit Windows 7 x64 to use only one core of one CPU?

I already tried this and rebooted but it seemed to have no effect. Task Manager still shows four columns that were all in use from time to time, and Device Manager still showed all 4 cores. And my BIOS setup does not have any option I can tweak.

(I have an Intel Core i5 520M.)

share|improve this question
    
why dp you want to do this? –  soandos Nov 27 '11 at 6:57
    
@soandos: Testing purposes. –  Mehrdad Nov 27 '11 at 7:00
    
@soandos Is this question obscure? –  wizlog Nov 27 '11 at 7:06
    
no... why would it be...? –  soandos Nov 27 '11 at 7:23

3 Answers 3

up vote 3 down vote accepted

Never mind!

Silly me -- I had adjusted the setting for Windows 8 instead of Windows 7 in msconfig!
Selecting the correct OS and setting the maximum number of processors definitely works.

share|improve this answer
    
Better to answer the question here rather than making a comment. (Answer being: MSConfig | Boot | Advanced Options | Select Number of Processor.) –  Richard Nov 27 '11 at 8:12
    
You can accept your own answer. –  kinokijuf Nov 27 '11 at 10:41
    
@kinokijuf: Not until tomorrow :P –  Mehrdad Nov 27 '11 at 19:19

Some PCs have a setting in the BIOS setup to disable all but a single core.

Also, if it's just a single program / process that you need to test, you could instead just set the processor affinity of that process. See: How to limit a process to a single CPU core?

share|improve this answer
    
No, I need it for the whole system. That's why I didn't ask for a single process. –  Mehrdad Nov 27 '11 at 7:20
    
Er, whoops, you already mentioned the lack of BIOS setting. –  rakslice Nov 27 '11 at 7:22

You can set the Number of Processors or Cores to be Used in Windows 7 using MSConfig.

You can find the all settings under the Boot tab in System Configuration, click on the Advanced options button.

Check this link [How to Set the Number of Processors or Cores to be Used by Windows 7] for step by step information.

If it does not work then try to do this:

 Type bcdedit /set onecpu on on a command prompt
    Reboot the system.
    When you are done playing, type 2 - Type: bcdedit /set onecpu off and reboot again.

that i got on SuperUser question.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.