Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am gaming on windows 7 with my Mac. The problem is that the function keys are set as the mac function keys. For example if I need to drink a healing potion in the game by hitting F1, my computer adjusts the brightness.

Is there any way to change the function keys. I know how to do this on the mac side of my computer but since most of my gaming is on Windows. I will need to know how to make these changes in windows 7.

share|improve this question
    
a lot of games have a setup screen, where you can change the key bindings. What game(s) are you using? –  Nate Koppenhaver Nov 27 '11 at 20:16
    
I'm playing a lot of games. Most of them don't allow key remapping. A lot of dollar value of games. So I am looking to remap keys in windows 7 rather to solve the problem of games which do not have remapping. –  claudius Nov 27 '11 at 20:40
    
so, you're actually running these games under Windows, not Mac? –  Nate Koppenhaver Nov 27 '11 at 20:42
3  
Please post this as an answer to your own question and accept it once possible (clicking the checkbox next to it) to help others that might have the same problem. –  Daniel Beck Nov 27 '11 at 21:10
1  
I think you guys want to change the title back as it is only relevant for windows 7 users who are using bootcamp. At least to my knowledge. Its not a key rebinding thing it just reverts the function keys back to normal for a mac keyboard. –  claudius Nov 28 '11 at 1:16

3 Answers 3

Go to Control Panel -> System -> Security -> Bootcamp and you can configure the keyboard from there.

posted @Claudius's comments as an answer; see here

share|improve this answer
    
And just in case here it is how to do that in case of Parallels kb.parallels.com/en/114309 –  Riapp Dec 6 '13 at 4:05

I have Boot Camp and wanted to use the F keys without pressing fn, however, the answer listed here was not exactly accurate and took me on a vexing detour.

[You cannot click through any path/directory "System -> Security -> Bootcamp"]

Here are the exact corrected steps:

Go to Control Panel -> Bootcamp

Select the "Keyboard" tab and then check-mark the option to "Use all F1, F2, etc. keys as standard function keys"

share|improve this answer
    
From the Windows menu 'Search Programs and Files' option type 'boot' and Windows finds 'Boot Camp', then as above (for those that cannot find BC through the Control Panel. Like me.) –  Neil Thompson Aug 4 '12 at 6:39

If you can't install Bootcamp itself for whatever reason (in my case, I'm just using an apple keyboard on a PC rather than dual-booting a mac), you can still get your function keys working correctly using the boot camp drivers pack on Apple Support.

Within the zip file, the BootCamp\Drivers\Apple folder contains two files of interest:

  • AppleKeyboardInstaller64.exe will install the driver to enable play/pause and the other magic function keys on your keyboard. Unfortunately it will also turn off FnLock, so you won't be able to use F8 as F8 by default.
  • BootCamp.msi is where the BootCamp control panel lives. You'll need to install it manually if you want the Fn keys settings to actually work.

To install the Boot Camp control panel

  1. Copy BootCamp.msi out of the zip file to someplace easy to remember.
  2. Start a command prompt as administrator.
  3. cd to whatever folder contains BootCamp.msi and run this command:

    msiexec /i BootCamp.msi
    
    • If you get an error about needing to run this package "from setup.exe," double check that you're actually running msiexec as administrator.
    • An error about missing files can be safely ignored.
  4. Let the installer reboot your machine

This will also have the side effect of installing Apple's boot selector service, which is functionally useless on a non-Mac machine. Fortunately, it's not necessary for the keyboard drivers to actually work. To remove it, after you've rebooted, open another command prompt as administrator and use this command:

sc delete AppleOssMgr
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.