Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Mac mini I picked up a few months ago to learn about developing iPhone/iPad apps; it's an Intel Core Duo running OSX 10.6. I'm running Xcode 3.2.6.

Can I not use this to test apps for updated iPhones?

When I try to add my new iPhone 4 (not s) to develop with I get this error:

The version of iOS on “<my iPhone>” does not match any of 
the versions of iOS supported for development with this 
installation of the iOS SDK. Please restore the device to 
a version of the OS listed below, or update to the latest 
version of the iOS SDK; which is available here.

OS Installed on iPhone
5.0 (9A334)

If I understand correctly, I need Xcode 4, which means I need OSX 10.7, which needs a newer processor than my Intel Core Duo. I'm also under the impression that it's almost impossible to update a Mac's hardware due to a variety of limitations they have.

So am I basically stuck with the option of buying a new Mac just to update Xcode, or is there a simpler alternative?

share|improve this question
1  
You picked it up used a few months ago, right? Mac minis with Core Duos (as opposed to Core 2 Duos) were discontinued years ago. I'd hate to think that a reseller found some dusty old stock and sold it to you unaware within the last few months. – Spiff Nov 27 '11 at 22:26
    
It was used, yeah. ($300) I just wanted something to play with. I suppose in retrospect it would have been more efficient to get a new one, but that would have more than doubled the price. – Bob Nov 27 '11 at 22:37
up vote 5 down vote accepted

If you're a member of the Mac or iOS Developer Programs ($99/year), you can download a version of Xcode 4 that will work with Snow Leopard. While the version of Xcode available through the Mac App Store is completely free and requires no membership, it does require Lion.

share|improve this answer
    
Are you sure? I just don't want to spend $100 and find out I STILL need a new computer, just so I can test my own apps. – Bob Nov 27 '11 at 22:38
    
I predict you could find a "trial" of Xcode 4.2 for Snow Leopard online (if you know what I mean) and take it for a spin before dropping $100. – ta.speot.is Nov 28 '11 at 0:08
    
I found this in Apple's Xcode 4.2 release notes: "You can install Xcode 4.2 for Mac OS X v10.6 Snow Leopard only if you have purchased an earlier release of Xcode." I don't know whether or not that means you can't install it even if you're a developer program member, but it does imply that there's an Xcode 4.2 for Snow Leopard out there. A YouTube video claims it's possible to bypass the App Store's Lion check and download it for free that way, but I have not tested this, and I'm not even sure it would have the 32-bit compiler you'd need for an older Intel Mac. – L2G Nov 28 '11 at 0:20
    
Well thanks, I'll have to give some thought to whether I'm reayd to be a paid developer, but at least I don't need to buy a new computer! – Bob Nov 28 '11 at 3:07
    
@L2G "You can install Xcode 4.2 for Mac OS X v10.6 Snow Leopard only if you have purchased an earlier release of Xcode." I think that if you install a previous version through that same iOS download center you could then upgrade... should be the same thing right? – DiscoveryOV Dec 7 '12 at 0:02

Xcode 4 for Snow Leopard is available to members of the iOS developer program. Xcode 4 does not require Lion.

share|improve this answer
    
It's also in the App Store. – vcsjones Nov 27 '11 at 21:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .