Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a lot of csv files at work with excel 2010. These have no formatting so Excel 2010 autoformats all the cells. I've found workarounds but the ones I have found require action for each file or each cell (i.e. adding a single quote).

My current workaround is using the "show formulas" option under formula auditing in the formulas tab. This seems to show the raw data (since they are just csv files there aren't formulas). If I could just keep this active so I don't have to turn it on.

share|improve this question
add comment

1 Answer

Try the settings in File > Options > Proofing > AutoCorrect Options....

Excel AutoCorrect

When you save a csv file, all the formatting is removed anyway.

share|improve this answer
    
I've turned all those options off. The files I have don't have formatting (as they are already csv), but excel formats stuff anyways. (i.e. 31151027498827 is shown as 3.1151E+13) I know I can force this column to prevent this but that requires an action every time i open another file. –  Samuel Nov 28 '11 at 14:30
    
@Samuel Maybe this Excel Add-In is what you are seeking for. It eases the process of opening csv/txt files and prevents Excel from converting the values. –  nixda Feb 4 '13 at 6:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.