Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use spaces to separate work modes. Lately, when I switch to a different space, Chrome shows up there too when it should just stay at its respective space. When I launch mission control, I am unable to drag and drop Chrome window on the space I want. Chrome simply pops up at every space, which is very very annoying, it's breaking my mode separations.

Any solutions or suggestions?

I am on Macbook Pro with OS X Lion v10.7.2 and Chrome v15.0.874.121

share|improve this question
    
Have you checked Spaces preferences whether Chrome is visible on every space? –  Daniel Beck Nov 28 '11 at 14:37
    
In Lion, there is only the Mission Control preferences, which has very limited options (nothing app specific). Other than that, I am not aware of Spaces preferences, where are they? –  Engin Erdogan Nov 28 '11 at 14:55
    
Not on a Mac right now, but have you checked Chrome's Dock icon context menu? –  Daniel Beck Nov 28 '11 at 15:34
    
You were right, thanks Daniel! In the context menu, you can assign it to a specific desktop vs all. That resolved it, thanks! Do you want to write that as an answer, so I can mark this closed? –  Engin Erdogan Nov 28 '11 at 15:43

1 Answer 1

up vote 0 down vote accepted

You can assign a space in the Dock item's context menu. Make sure you haven't selected to have Chrome appear on all spaces.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.