Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a shared folder on my network that holds my music. I recently converted my flac to mp3, and want to move the flac to the network folder. So I mounted the network share with sudo mount -o username=Robert //192.168.1.56/music /mnt/networkmusic and then navigated to the folders with flac in them.

Then, in that folder, I made sure that every subfolder was one I wanted moved (they were) and did for f in *; do sudo mv "$f"/ /mnt/networkmusic; done which worked and moved a few of them, but then started giving me errors, so I tried it again and it didn't work at all, just gave me this error

mv: accessing '/mnt/networkmusic': Cannot allocate memory

The shared folder is on a windows 7 PC. I think I've read that a setting needs changed to allow it to operate more like a server, but I'm not sure where I read that or even how to set it up. Any ideas?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

Set the following registry key to 1;

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

and set the following registry key to 3:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

found it here: http://www.codenition.com/solving-cannot-allocate-memory-error-on-windows-7-linux-cifs-mounts

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.