Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My coworkers started yelling at me today because apparently I started screaming in their ears during a Google hangout. And sure enough, when I go to the Microphone settings dialog, I can see the level being auto-adjusted constantly; sometimes way too high.

I don't think this has happened previously; at least nobody ever complained. Can I find out who is doing that auto-adjusting, and more importantly, can I turn it off? I couldn't find any related setting in the recording device settings.

I'm using Windows 7 64bit, and (I'm mentioning this because the theory has come up that it may be related) I don't have Skype running.

share|improve this question
    
I have this exact same problem. I've been scouring the web searching for a solution for weeks and so far have been completely unsuccessful. I tried johnh's solution, below, and it did nothing (in fact that setting was already set) and all my drivers as far as I can tell are completely up to date. –  Phairoh Dec 5 '11 at 1:37

3 Answers 3

Just found a solution for this:

First, Close your browser or any other programs that are using your microphone.

Open Regedit Navigate to [HKEY_CURRENT_USER\Software\Google\Google Talk Plugin]

In this section it should have a string value named "audio-flags" with a value of 3

Change this value to one so it reads like "audio-flags"="1" or as seen below in the picture.

Once you've done all this you can open your browser and launch googletalk/hangouts. I've noticed that if I ever open the hangouts settings tab to adjust any settings it does reset this setting. So be prepared to do it over again if you do that (and subsequently reset your browser).

hangout fix

I have confirmed this does work.

share|improve this answer
    
Recently I've found the value to be 15 instead of 3. I wonder what the two new flags mean. –  lapo Jan 13 '13 at 1:15
1  
I have this issue but aint got no GTalk plugin. –  Cobra_Fast Jun 2 '13 at 20:19
    
If you find it at 15, adjust it to 13 instead of 1. (you are clearing bit 1, the second bit from the right) –  D Coetzee Nov 10 '13 at 7:39

I've found the Windows 7 drivers for certain Soundblaster families to be pretty awful (even though you don't specifiy a Soundblaster) and one of the major grievances for me, was the constant manipulation of the volume control. There's a setting that allows Windows to change the volume of applications if you send/receive phone calls. For whatever reason, I found the volume "reduction" would sometimes result in the volume settings being cranked right up or they'd consistently mute themselves. What solved it for me was to change the following:

  1. Right-click the volume control and select Recording devices from the context menu.
  2. Select the Communications tab.
  3. Change the radio button setting to Do nothing.

If that still doesn't work then you could try updating your drivers as well.

share|improve this answer
    
Thanks! And I was already wondering why the volume level of my microphone recording varied all the time. It was due to exactly this setting. –  orschiro Jul 13 '12 at 13:02

Not Cured But Very Manageable By now you are probably familiar with how to get to the microphone array volume adjustment under sound in the control panel.... directly under that is the microphone boost adjustment which is rated in dBs. These two adjustments work together...... If the boost is high, the volume will automatically adjust lower, and sometimes to zero. If the boost is at zero, the volume will go to full (1oo%). I have discovered that if the boost is set at 50% (the only option besides 0 and the full 20dB) the volume will still change, but will stay within a reasonable range, and the change is not enough to bother the person to whom I am communicating... I have Windows Home Premium on an HP laptop, and the problem only occurs while I am using the Gmail phone.

This problem is a real pain.... good luck to all!!!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.