Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have used the command "netsh WFP Show State" to dump to disk (wfpstate.xml) a list of all active windows filters, and found a filter called "Port Scanning Prevention Filter". For diagnostic purposes, I need to test disabling this particular filter, but I cannot find this within the UI for Windows Firewall (Windows 7 Ultimate x64 Sp1). Below is the full XML representation of the filter in question.

How do I disable this specific filter? How would I re-enable this filter?

        <name>Port Scanning Prevention Filter</name>
        <description>This filter prevents port scanning.</description>
    <filterCondition numItems="1">
share|improve this question
did you search the registry for that "filter key" – Moab Nov 29 '11 at 16:54
Thank you for the suggestion, but there were no search results in the registry for that key, with or without the curly braces around the GUID. – JNadal Nov 29 '11 at 17:21

Ok so you can't shut down that particular rule; it is a system default!

Take a look at this TechNet article regarding the windows scanning prevention filter.

Any port that has been explicitly opened by the firewall but does not have an application listening on that port will still have its packets dropped silently by default. This helps to harden the windows installation.

To see which ports have active listeners type the following command into an administrative command prompt:

netstat -ab

If the target port you are trying to open does not have an active listener then you will see packets being dropped silently (I.E. not being added to the firewall logs). As you may have noticed the dropped packets will still show up in the Netsh diagnostic logs. See this technet article regarding Netsh diagnostic logging for more information.

So see if your application is listening on the appropriate port or functioning at all!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.