Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've created encoded a MPEG-4 file with mplayer and placed it on a DVD. The file is identified as

RIFF (little-endian) data, AVI, 320 x 240, 25.00 fps, video: FFMpeg MPEG-4, audio: uncompressed PCM (stereo, 96000 Hz)

I've tried playing it on a Samsung 1080p DVD player and the codecs were not recognised. There are no firmware upgrades available for my region (Romania).

How should I pick the codecs to make sure that the files are readable by this DVD player?


Update: The command line I used is similar to

mencoder -dvd 2 -ovc lavc -lavcopts vcodec=mpeg4:vpass=1 -oac copy -o movie.avi
mencoder -dvd 2 -ovc lavc -lavcopts vcodec=mpeg4:vpass=2 -oac copy -o movie.avi
share|improve this question
    
Do you know what command line you used to encode with MEncoder? – pelms Sep 5 '09 at 13:49
up vote 3 down vote accepted

Your Samsung 1080p DVD Player does not support h.264 MP4, only DivX/XviD codecs.

I recommend you try these settings :

Video Codec : DivX/XviD (either one will do)
Frame Rate : 25 or 29.7 (25 for better file size)
Video Size : Max 640 width (for height go with the aspect ratio of your video)
Audio Codec : MP3 128kbps Stereo VBR

It should play now - I recommend you use Handbrake to encode.

share|improve this answer
    
+1 for Handbrake ref. – nik Sep 5 '09 at 13:43
    
Thanks, I'll try these settings. – Robert Munteanu Sep 5 '09 at 20:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .