Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Windows 7 Professional 64-bit SP1, genuinely activated.

I want to install Windows Media Player 12 but it seems I require the "Media Feature Pack". I can't seem to find a good installer. I've tried at least four of them, both 64-bit and 32-bit. I am told:

This update is not applicable to your computer.

I've searched for a long time but to no avail. Here's one example:

http://www.microsoft.com/download/en/details.aspx?id=16546

Any ideas how I can get a working Media Feature Pack installed?

share|improve this question
    
Are you sure you have the N or KN edition of Windows 7? – Harry Johnston Nov 29 '11 at 1:16
1  
I don't have N or KN.. i guess. So how do i get windows media player 12 for non-N-or-KN? – Kirby Nov 29 '11 at 1:24
up vote 4 down vote accepted

From the link you posted:

Windows 7 N and Windows 7 KN editions include the same functionality as Windows 7, except that these versions of Windows do not include Windows Media Player, and related technologies.

End-user customers can enable the media functionality to work properly by installing the Windows Media Feature Pack for Windows 7 N and Windows 7 KN (KB968211).

Do you have N or KN?

share|improve this answer
    
How do i determine? I have neither an N or KN in my Computer > properties – Kirby Nov 29 '11 at 1:21
    
I imagine you're infering that i have neither N nor KN? :-p – Kirby Nov 29 '11 at 1:21
1  
Pretty much. I have never seen a N or KN install, so I do not know if it should be displayed along the version number (although I guess so), but this should tell for sure: Go to Control Panel -> Programs and Features -> Turn Windows Features on or off and look for Media Features. If it is there, you do not have N or KN. – Dennis Nov 29 '11 at 1:27
    
Selected this answer because it points out that the misread is N or KN only.. and the correct answer was included in the comments. :) – Kirby Nov 29 '11 at 1:28

Go to Control Panel and select Programs and Features.

Select "Turn Windows features on or off".

Under "Media Features" turn on (tick) Windows Media Player. Press OK.

share|improve this answer
    
yep, i'm dumb... thank you... this did the tick. – Kirby Nov 29 '11 at 1:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .