Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

EDIT: Microsoft support has confirmed that it's a bug with PowerPoint 2007 SP3.


I have recently encountered a problem with the "Save as PDF/XPS" add-in for PowerPoint 2007. When I use "Save as PDF/XPS" to create a PDF version of my presentation, some slides are only partially included in the resulting PDF file. For example, this: PPT slide (download the PPTX file here)

is reduced to this (in Adobe Reader X or Acrobat Pro X (both 10.1.1)): PDF slide (download the PDF file here)

So far, I have only encountered this with slides that contain animation elements, but which part of the elements remain in the PDF version appears not to have anything to do with the order in which the animated elements appear, so that might just be a coincidence.

Update: The problem persists even if I "un-animate" the slides (removing the animation but leaving the previously animated elements intact).

When viewing the affected slides in Acrobat Reader, it sometimes complains about the file containing invalid elements, and that I should complain to whoever generated the PDF file...

Update 2:

I have just installed Office 2007 on a new Windows 7 x64 PC. With the original Office version (12.0.4518.1014 MSO 12.0.6562.5003), a correct PDF file is generated. After installation of SP3 (12.0.6606.1000 SP3 MSO 12.0.6607.1000) a corrupt PDF file is generated. Today's Microsoft Updates (to PowerPoint version 12.0.6654.5000) haven't changed anything, by the way.

Update 3:

I have opened a tech support incident with Microsoft. They have confirmed the "limitation", as they called it, and it is indeed limited to 2007 SP 3 only. They are going to pass it on to the developers but they can't say when or even if a fix would be forthcoming, so I guess I'll upgrade to 2010...

share|improve this question
    
I haven't heard of this one but would like to see an example one/two slide file (one that you won't mind my passing along to others, including an acquaintance or two at MS who might be able to help). Email the file to steve at-sign pptools dot com and quote your message above in the body of the email, please. Thanks –  Steve Rindsberg Nov 29 '11 at 16:10
    
@SteveRindsberg: Thank you for your kind offer! I will do so when I get back into work tomorrow morning. –  Tim Pietzcker Nov 29 '11 at 17:51
    
sorry for the delayed reply. I see the problem (can't reproduce it because I haven't yet applied SP3, and given that it seems to cause the problem, probably won't apply it just yet!) Interestingly, if I open your PDF in PDFXchange Viewer (Tracker software, free) it looks OK except that the little half-circles in the upper left of the slide aren't filled, whereas they are when I make a PDF. I'll pass this along to my friends. –  Steve Rindsberg Dec 6 '11 at 21:31
add comment

4 Answers 4

up vote 3 down vote accepted
+50

I suppose you are using the 2007 Microsoft Office add-in Save as PDF or XPS.

This add-in does not support animations, transitions or sounds, so they will come out as blank.

One solution I can think of is to replace the problematic elements by images.

If this is unacceptable, it would help if you could post a small example of such a presentation and the generated pdf, so we could have a look at them, using some file-sharing site such as mediafire or rapidshare.

[EDIT]

Hold everything : I can see your pdf file, and it is perfect.
So there is nothing wrong with your Office 2007 : It is your pdf viewer that is brain-dead.

With what product are you viewing the pdf ? My own is Foxit Reader.

[EDIT2]

Complete reversal : Trying out your pdf file on GhostScript gave the following error and displayed exactly the same incomplete page as you included in the post

enter image description here

Conclusion: You have found a bug in the PDF add-in of Office 2007. Perhaps, as you say, it was introduced by Office 2007 Service Pack 3. Foxit Reader is smart enough to "repair" the damage, but Adobe Reader is not.

Reproducing the problem on a clean install will be instructive. I would suggest to install the Office service packs one-by-one, meaning SP1, SP2 and SP3, to find when was the bug introduced. It may only be triggered by vector images, but nothing is sure.

The only solution would seem to be to either use a third-party product to produce the pdf, so avoiding Office, or maybe using OpenOffice/LibreOffice, or maybe replacing the vector images by ordinary ones, and lastly reporting the bug to Microsoft and waiting for SP4 (or SP5 or 6).

share|improve this answer
    
I don't know if it's an add-in, it always was one of the options in the "Office"-"Save As..." menu. And the thing is, it always used to work and stopped working a few weeks ago. Good idea about the file-sharing site; I'll find a small example and post it. –  Tim Pietzcker Dec 12 '11 at 13:24
    
OK, I have uploaded two files and linked them in the question. Thanks for looking at them! –  Tim Pietzcker Dec 12 '11 at 13:40
    
Important edit above. –  harrymc Dec 13 '11 at 9:12
    
I'm using Adobe Reader 10.1.1 (our university's printing center uses Acrobat Professional 10, and they see the same problems - and I'm dependent on them for the printouts). Both complain of "invalid elements" in the PDF file, where Foxit appears to be more lenient. So that's not an alternative for me, unfortunately. –  Tim Pietzcker Dec 13 '11 at 10:41
    
I tried Adobe Reader X and effectively the error is there. This ghostscript thread seems to hint that images whose size is greater than 8100 bytes cause this error in Adobe Reader. You could try shrinking the images. –  harrymc Dec 13 '11 at 11:56
show 3 more comments

Similar problem using Excel:

  • Saving workbook with some graphs, the resulting PDF was also broken.
  • Same workbook in a different computer (with SP2), and it worked fine.
  • Upgraded to SP3, PDF broke again.

So it does look like SP3 breaks 'Save as PDF' functionality for the whole of Office and not limited to PowerPoint.

share|improve this answer
    
Thanks Neo, I had been expecting this since it's an Office-wide add-in, not just for PowerPoint. See my edit to the question for an update. –  Tim Pietzcker Mar 7 '12 at 11:35
add comment

Here's another example of a corrupted pdf file created by Powerpoint 2007. http://dl.dropbox.com/u/18839687/Example%20of%20corrupted%20pdf%20from%20Powerpoint.pdf

It opens fine in Foxit, but not with Adobe. My workaround was to create a pdf by using the Bullzip pdf printer tool, which installs as a printer device, and you "print" to it. It's output pdf opens fine with both Foxit and Adobe. I haven't tried other such pdf printer tools - there are several.

I'll be watching for a real fix for this. I use PP a lot!

Don Travis

share|improve this answer
add comment

I too have encountered the very same issue for a couple of our users.

They are all using Windows XP and Microsoft Office 2007 SP3.

They all have separate PowerPoint files (.pptx) however in both their presentations they have copied and pasted in the exact same slide from a previous PowerPoint file - i.e. both their PowerPoint files feature one identical slide pasted in from another presentation.

They are using the native save to PDF feature in Office 2007 by going to 'Office Orb > Save As > PDF or XPS'.

When viewing the page / slide in question in the outputted PDF using Adobe Reader 10 or 11, some text boxes are missing.

Further, the following error appears when viewing the page in the PDF: 'An error exists on this page. Acrobat may not display the page correctly. Please contact the person who created the PDF document to correct the problem'.

After a thorough investigation, I discovered that in the PowerPoint slide, a SmartArt graphic with grouped text boxes was causing the slide to corrupt / output incorrectly in the PDF. As a workaround to the problem, I selected the SmartArt graphic, converted it to shapes by right-clicking it and selecting 'Convert To Shapes', and also ungrouped the text boxes which were grouped together. After doing this, the slide outputted correctly to PDF.

As for the 'Slide.pptx' PowerPoint presentation attached in the original post, after some troubleshooting / tweaking I managed to find the cause of the problem for this presentation. The issue seems to be the gradient fill of the peach coloured 4-point shape on the left hand side in the background. The following workaround resolved the issue:

  1. Ungroup the SmartArt graphic and 4-point shape on the left hand side (the red pie chart and the peach coloured 4-point shape which is in the background).
  2. Select the peach coloured 4-point shape, right-click it then go to 'Format Shape...' (you might need to move the red pie chart out of the way first or send the pie chart to the back for now).
  3. In Fill settings, either switch to a solid fill, or alternatively, keep with a gradient fill but using type 'Rectangular' instead of 'Linear'.

After following those steps, the 'Slide.pptx' presentation will save and appear in PDF correctly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.