Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having some troubles with mapped network drives on Windows 7. We have several Windows 7 machines that are trying to automatically connect to network shares (that are on a Windows 2008 server and an Ubuntu 8.04 samba share).
The drives do not autoconnect on login because the network connections are somehow dropping on boot and then reconnecting automatically.

This is what happens:

  • User logs in (domain user, any user works so on login there is a network connection)
  • Desktop appears
  • A red cross appears over the network symbol
  • A messages pops up with the warning that not all network drives could be reattached
  • The red cross disappears
  • Clicking on the network drives from explorer connects that automatically

We have found 1 fix though, which is setting a static IP address. While this works, it is not the solution we are looking for.

Does anyone know why Windows 7 tries to renegotiate with the dhcp server on login? And whether this can be disabled?

share|improve this question
    
Server 2008 requires it to the the only DHCP server on the local network, period, no exceptions, this may or may not be your problem, Hard addressing of workstations is best in a domain environment, I use addresses above .50 Is there a reason hard addressing is not a good solution for you? –  Moab Nov 29 '11 at 15:55
    
Are you using WiFi ? Does this article help ? –  harrymc Dec 5 '11 at 9:55

3 Answers 3

up vote 0 down vote accepted
+50

You could potentially look into writing a logon script that reconnects the network drives using commands like

net use x: \\server\share

This script can be set (through group policy) to run with each user logon and connect the appropriate drives

share|improve this answer

I ran into this problem a while back. The cause in my case turned out to be spanning-tree. On Cisco switches, there is a 50 second period of time when a port comes up during with no traffic is passed while the switch listens, learns, etc to prevent loops in the network. Turning on portfast on each port on the switch disables spanning-tree which allows the port to become active much quicker. I noticed the problem was occurring on newer PC's because they were booting up faster. On the switches, for any port that is connected to a workstation, enter switchport host. This will turn on portfast (disable spanning-tree so be careful not to create a loop), turn off trunking, CDP and VTP.

share|improve this answer

No point hard addressing machines in this day and age, although it does often sort out some problems. I agree, just create a logon script for users and apply it in the Properties of the object in AD.

This will map the drives automatically.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.