Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am in strange condition right now. I am not able to access facebook.

Once I open the facebook it just loads the localhost.

I know we can set it from host file. But just have a look at my host file. There is nothig which redirects facebook to localhost. Is there any other way we can set this redirection? I am on windows 7.

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#   127.0.0.1       localhost
#   ::1             localhost
#127.0.0.1 local

Ping facebook.com NS Lookup

share|improve this question

migrated from serverfault.com Nov 29 '11 at 16:24

This question came from our site for system and network administrators.

4  
Wouldn't that be a good thing not to be able to log onto Facebook? – xeon Nov 29 '11 at 16:14
    
Are you sure your company isn't blocking this? – ceejayoz Nov 29 '11 at 16:25
    
@ceejayoz have just talked with them, but they are not blocking that. – Avinash Nov 29 '11 at 16:30

There are a few options.

  • hosts file (you already tried)
  • DNS Cache (clear it with ipconfig /flushdns)
  • DNS Server (check it with nslookup as posted above)

probably the "ipconfig /flushdns" will solve the problem as your DNS Server should have the proper records.

also dont forget to check your DNS Server settings

ipconfig /all should show those, they need to be reachable.

share|improve this answer
    
how to run "iptables /flushdns"? As I am getting "Windows can not find iptables" – Avinash Nov 29 '11 at 16:17
    
you can run the iptables command in a command box (cmd.exe) – Flash Nov 29 '11 at 16:18
    
ipconfig /flushdns is executing that I have tried but iptables not working.. – Avinash Nov 29 '11 at 16:19
    
What are you talking about? iptables is the interface to netfilter on most Linux distributions. It's not a Windows application and even on Linux, it doesn't have anything to do with the DNS cache. – MDMarra Nov 29 '11 at 16:21
    
Very sorry, I ment ipconfig. changed the answer (fail /me for doing both linux and windows randomly) – Flash Nov 29 '11 at 16:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .