Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Hyper-V physical machine along with two standard laptops running within my LAN (connected by an ASUS-RT56U router). The physical server runs Windows Hyper-V Server 2008 R2, with two Windows Server 2008 R2 (full) guest VMs installed and running within.

Both laptops run Windows 7. All OSs are 64-bit.

Opening up Network in Windows Explorer on either of the two laptops displays both of the laptops in the LAN fine. However, neither of the guest VMs on the server (nor the host itself) are displayed. Indeed, the guest VMs can not see each other in Network view either. I can ping all computers (laptops and servers) without problems from within the LAN, but all of the servers are simply not visible from anywhere.

In addition, the Network Map screen (accessible via Network and Sharing centre) gives me an error message:

"An error happened during the mapping process."

And I'm suspecting this might have something to do with how LLTP (Link Layer Topology Protocol) is working on the network. Worth noting though is that before my server was on the network, the Network Map screen displayed fine (as far as I can remember).

share|improve this question
    
Is the firewall blocking Windows Print and File services? (Network Map doesn't work here on H-V either, I understand there is a setting that can change this.) –  Richard Nov 30 '11 at 8:03
    
Afraid not. That's turned on. –  Noldorin Nov 30 '11 at 15:41
    
After a bit of playing around, I've got the Network view in Win Explorer working (displaying all servers), but Network Map is still having the same issue... –  Noldorin Nov 30 '11 at 15:42
    
@Richard: Any chance you could find out what setting that is to get Hyper-V to let Network Map work? –  Noldorin Nov 30 '11 at 19:08
    
It was in an article I read, some configuration change to be made. But I cannot recall any details. Time to spend time with search engines... then you can answer your own question. –  Richard Nov 30 '11 at 21:03
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.