Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After (hopefully) scrubbing viruses out of a Windows 7 installation (after deciding not to simply run over the laptop repeatedly with my car), I've got everything almost back to normal. The only lingering issue I have is that for my non-admin users, the ".exe" file extension doesn't work. That is, clicking on the various desktop application links results in a "How do you want to open this?" dialog.

I've been through the alleged registry fixing from "winhelponline" and that had absolutely no effect. I've tried running "assoc" for the affected users, but it reports the .exe association to be "exefile" even though it persistently does not work.

Right-clicking on a desktop icon and then choosing "start" does successfully open an application, but that's clearly a terrible situation.

For my admin user, things seem to work fine.

What do I need to do to get things working?

share|improve this question
    
I assume that you restarted after making regisry changes? – soandos Nov 30 '11 at 1:11
1  
Yes, it being Windows I've restarted about 800 times :-) – Pointy Nov 30 '11 at 1:28
    
possible duplicate of How do I fix broken .exe file association in Windows Vista? – Canadian Luke Jul 29 '14 at 3:36
2  
Possible duplicate of How to revert an accidental file association – Kevin Panko Jan 25 at 14:42
    
I'm voting to close this question as a dupe of this other question because the other question has better answers, even though this one was posted earlier. This dupe network is being discussed on Meta. – Ben N Jan 25 at 16:56
up vote 5 down vote accepted

Open Notepad and save a text file (using a .reg extension) with the following content:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile\shell\open\command]
@="\"%1\" %*"

Double click the file then reboot.

DISCLAIMER: Use at your OWN risk! There is no guarantee that this will work!

share|improve this answer
1  
I've done exactly this. It had absolutely no effect. (edit at least I think that's what one of the random .bat files that purported to fix it did. I can try it however. Can you tell me what that would look like from within regedit?) – Pointy Nov 30 '11 at 1:38
    
Also, what's the explanation for things working fine for my admin user, but not for non-admins? – Pointy Nov 30 '11 at 1:40
    
Also, thanks :-) – Pointy Nov 30 '11 at 1:40
    
When viewing the registry, under the path given, you would see a text value of: "%1" %* – Myrddin Emrys Nov 30 '11 at 1:45
3  
Well, it has to be a .reg file, not a bat file. Was it a reg file you ran? And as for admins, the [virus] thing might have edited your registry in only HKEY_LOCAL_USER section. If you use HKEY_CLASSES_ROOT, then the changes are global. – itdoesntwork Nov 30 '11 at 1:48

protected by Community May 27 '15 at 11:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.