Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Crunchbang Linux with Openbox and I would like to have Synergy (http://synergy-foss.org/) autostart at the login screen.

I tried following: https://wiki.archlinux.org/index.php/Synergy however I'm a bit new to Linux and I'm not quite sure how I should go about doing that.

Any ideas?

EDIT:

I want it to be the client.

I can get it to work after I manually login with the keyboard and mouse that are connected to it and then adding Synergy to the autostart.sh

What I want is Synergy to start before logging in, so I don't have to have a keyboard and mouse connected to the computer to login to it

share|improve this question
    
where exactly do you get stuck? Do you want this system to be the client or the server? –  Journeyman Geek Nov 30 '11 at 4:38
    
ah sorry I want it to be the client –  Mike Hagstrom Nov 30 '11 at 4:55
add comment

2 Answers

up vote 2 down vote accepted

Openbox uses a file at ~/.config/openbox/autostart.sh to start files. You can add or remove things from this file.

In #!, you'll probably want to comment out the line that has cb-fortune in it, to remove the annoying "Statler Says" messages.

Since you're using #!, there's an easy way to get to this config. Hit SUPER + SPACE, and go to SETTINGS > OPENBOX CONFIG > EDIT AUTOSTART.SH

At the bottom, add a line that says synergyc server-host-name &, replacing server-host-name with... well... the server host name, save it, and restart with SETTINGS > OPENBOX CONFIG > RESTART

share|improve this answer
1  
I got that to work however, I still have to login with the keyboard and mouse connected to the Crunchbang computer instead of the one from my Windows 7 Synergy server computer. –  Mike Hagstrom Nov 30 '11 at 4:57
    
I've never used synergy, I can't be more help past setting things up to autostart. I'll look into it, though, it's something I've wanted to install. –  Rob Nov 30 '11 at 4:58
    
Have you read through man synergyc and set up a config file? –  Rob Nov 30 '11 at 5:01
    
Oh, I get your problem, since you aren't logged in, it isn't started. You'll want to have it run when the system boots, not when you log in. Hold on a minute, let me try a few things. –  Rob Nov 30 '11 at 5:04
add comment

You can add it to /etc/rc.local

sudo nano /etc/rc.local

I made it look something like this:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits. 
#
# By default this script does nothing.

## Synergy Test thingy
echo "Starting Synergy Client"
synergyc lolhosttest

exit 0

If you switch to TTY1 (ctrl + alt + f1) you'll see it say "Starting Synergy Client" as the very last thing before prompting a log-in. If you do log in through the tty, and do top or htop, you'll see it's running. Since openbox wasn't started, obviously autostart.sh has nothing to do with it.

share|improve this answer
    
Sadly this did not work I have also tried: (sleep 10; DISPLAY=:0 synergyc 192.168.5.55)& and that does not work as well, it simply isn't starting at the login screen, I'm thinking it may have something to do with SLiM (slim.berlios.de) –  Mike Hagstrom Nov 30 '11 at 6:45
    
Putting it in rc.local should start it as the kernel loads. :/ Join the IRC channel and ask in there, or check out the #! forums. Just load up xchat and it'll put you in the #! irc, and the forums are at crunchbanglinux.org still. –  Rob Nov 30 '11 at 13:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.