Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have GNOME3 on Debian and cannot for the life of me figure out how to customize the login screen, either background or box itself. Thoughts? I'm good with the terminal :P

Also, Compiz does not do anything, even when enabled... Wobbly windows don't work :'(

share|improve this question
1  
I'll have an answer for you when I get home and onto my #! box. Are you using the new image with SLiM (Just came out recently) or the older image with gdm? I assume gdm since it's tagged that way. I'm not sure if compiz would work with openbox or xfce, which is what #! statler comes with (the new one is only openbox) –  Rob Nov 30 '11 at 18:17
    
@Rob I think I... removed gdm and installed GNOME... –  tekknolagi Dec 1 '11 at 2:42
    
Xfce? Not sure. –  tekknolagi Dec 1 '11 at 2:43
    
gdm is the login screen for gnome. You can't use compiz effects without changing the window manager to compiz. –  Rob Dec 1 '11 at 4:41
    
@Rob i did that, and even so... :-/ –  tekknolagi Dec 1 '11 at 5:05
add comment

2 Answers

I had the same problem. I didn't much look into customizing it in Gnome, because I knew I liked the KDM login screen. If you install KDM, you can set that as your desktop manager, and then download themes to use with it or create your own theme. It's been a while since I did this, so I can't remember the exact commands, but I'll pull up my desktop on my phone and figure out what they are.

Okay, you'll need to run sudo apt-get groupinstall "KDE Software Compilation" to install KDE. This will install the KDM you want to use, as well as allow you to load KDE to chenge the KDM options. Then you'll need to edit /etc/sysconfig/desktop (or create the file if it's not there) to include the lines

DESKTOP="KDE"
DISPLAYMANAGER="KDE"

Then reboot, and it'll use KDM instead of GDM! The first time you do it, you may have to tell it to use Gnome instead of KDE. I can't remember whether I had to or not. You can download KDM themes here, and then load KDE to change which one you are using.

Please see my comment for another method which I haven't tested, but is probably better.

share|improve this answer
    
yum won't do anything on #!, it's a debian based distro and uses apt –  Rob Nov 30 '11 at 18:35
    
Alternatively, you can instead run sudo apt-get install kdm, then download a theme, unpack it, move it to /usr/share/apps/kdm/themes/, then edit /etc/kde3/kdm/kdmrc to make the line Theme=(themepath) point to the new theme. I haven't done this, but it should work. I wish I had done it that way, as then I wouldn't have to go through and get rid of all the KDE applications -.- –  SaintWacko Nov 30 '11 at 18:39
    
Oh, oops. Guess I'll look up the apt commands and fix my answer :D –  SaintWacko Nov 30 '11 at 18:40
    
I just got rid of gdm and started using .xinit. Feels good man. –  Rob Nov 30 '11 at 18:45
    
What are the benefits of using .xinit over a display manager? –  SaintWacko Nov 30 '11 at 18:49
show 6 more comments

Hit ALT + F2 and enter gksudo gdmsetup into the box. You can change your theme from here.

share|improve this answer
    
Nope, this window comes up different. –  tekknolagi Dec 1 '11 at 2:42
    
Hmm, something weird with your set up for sure, you should be able to use gdmsetup to change the theme, it's under the LOCAL tab. The default is called "CrunchBang Statler". If you recently downloaded and installed #! though, you aren't using gdm, but are using SLiM instead. –  Rob Dec 1 '11 at 4:42
    
I recently installed gnome-desktop which removed gdm i believe... –  tekknolagi Dec 1 '11 at 4:47
    
Yeah, that does remove GDM. Edit your question to ask about gnome and change #! to debian, since you aren't really using #! default gdm anymore. –  Rob Dec 1 '11 at 13:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.