Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have for a long time used KeyRemap4MacBook in Snow Leopard. I have always stayed on top of OS update. Today, suddenly my CapsLock no longer was remapped to Control, but it was just a regular CapsLock. So I went into the settings for KeyRemap4MacBook and noticed that CapsLock could no longer be set. Instead it gave a link to PCKeyboardHack. So I downloaded that and tried to use it. But when I try to select the Control key to remap to, it just becomes some kind erratic delete key or something. Definitely not a Control key.

share|improve this question
I thought PCKeyboardHack was for PC keyboards. So did you update KeyRemap and then it stopped working? – slhck Nov 30 '11 at 9:43
@slhck, weird thing, I didn't do anything. KeyRemap maybe can autoupdate? – Prof. Falken Nov 30 '11 at 9:46
Not that I know of, or at least not without your consent, as I think it requires admin privileges and you'd have to enter your password. Can you maybe try to reinstall KeyRemap? – slhck Nov 30 '11 at 9:52
@slhck, tried that a few times. KeyRemap actually says in the CapsLock line that you should instead use PCKeyboardHack for CapsLock support. I am trying older versions of KeyRemap now. – Prof. Falken Nov 30 '11 at 10:01
up vote 3 down vote accepted

Reading comprehension is important... my defense, it DID WORK for many months without PCKeyboardHack, how I don't know. Maybe I upgraded KeyRemap4MacBook and then did not reboot until now.

Anyway, the solution is to use PCKeyboardHack and then to actually follow the instructions. In particular step 3,``open "System Preferences > Keyboard > Modifier Keys..." and change CapsLock configuration to "No Action":´´ enter image description here

share|improve this answer
And now that setting reverted again. Strange, I had to go in and do the No Action setting once more. – Prof. Falken Dec 20 '11 at 9:50
And again. It's when I type some weird combo it happens... – Prof. Falken Jan 5 '12 at 10:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.