Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Acer Aspire One netbook, which I'm using with Ubutu Netboox Remix 9.04. With a clean install, suspend seemed to be working fine. However, now that I've installed quite a lot of extra packages and done some configuring (bluetooth dialup, and such), I seem to have lost the suspend functionality.

When I try to go to suspend, the screen only shows a blinking text-mode cursor at the top left corner, and the computer never gets suspended. The only way out is a hard restart.

How can I troubleshoot the issue? For example, are there some specific log files I should be looking at, or such? Since the suspend was working on the clean install (and on the original linpus linux installation that came with the computer) I know this is not an unsolveable hardware compatibility problem. Removing/installing packages one by one would, of course, be an option - but this would be awfully time-consuming, since I have a lot of extra packages and no idea when the problem appeared. As far as I understand, I didn't install anything too weird that might be expected to cause such issues.

EDIT: The new release, Ubuntu Netbook Remix 9.10, fixed this. I can now suspend the netbook even with the memory extension mounted. This, however, does not work exactly how I'd hope... More information in new thread: Force unmount in Ubuntu, to fix problems after netbook sleep mode

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Suspend is known not to work with SD cards inserted. Remove SD cards and other peripherals you may have attached before suspend. There's a good explanation on the Gentoo wiki as to why suspend is problematic with an SD card present: SD Cards and Suspend

If the problem persists, check the logs in /var/log, specifically syslog, messages and Xorg.0.log. There's a handy GUI tool to view the system logs that you can use: System > Administration > Log File Viewer (or something similar).

You should also look at the Ubuntu Community documentation on Acer Aspire One here and here.

share|improve this answer
    
Yowch! That's bad, since my laptop has an internal small SSD, so I use an extension card for my larger storage needs. Unfortunately, a quick test confirmed that this was indeed the source of my problem. Thanks for the answer - now I at least know what causes this. It's really, really hard to like linux with stuff like this happening, but I'll just keep on trying. –  Ilari Kajaste Sep 7 '09 at 7:41
    
The Gentoo wiki link was really good. Especially this: "There is another option that does not require changing the kernel. Use LVM on your SD card and you will have no problems with resume." So I guess now I'll just have to figure out what exactly is LVM and how to use it on my card... –  Ilari Kajaste Sep 7 '09 at 7:52

There is a wiki post on the Netbook Remix help for the Aspire One which details how to fix this. You add a script that will unmount the cards on sleep, and re-mount them at wake. I implemented this on my Aspire One ZG5 (aoa110-1955) and all is well.

Here are the instructions from that page with some newbie-friendliness baked in:

1 - open the text editor found in Accessories(? I think, don't have the Aspire in front of me), copy/paste the following:

# Drop to: /etc/pm/sleep.d
# Use this script to prevent data loss on mounted MMC/SD
# cards. It syncs data and umounts all mmcblk devices prior to
# suspend, and cancels suspend if umounting was not possible
# (i.e: something locks a file)
case "${1}" in
    hibernate|suspend)
        /bin/sync
        for drive in $( /bin/ls /dev/mmcblk?p* ); do
        /bin/umount ${drive} > /dev/null
        # If umount failed: abort suspend
        if [ $? -gt 0 ]; then
        # Test if device keeps mounted. Previous command could fail
        # (i.e device was not mounted) with a non-stopper
        # problem for the suspend process.
        /bin/mount | /bin/grep ${drive}
        if [ $? -eq 0 ]; then
            exit 1
        fi
        fi
    done
    ;;
#    resume|thaw)
##       Do nothing. All devices will be automatically mounted again.   
#       ;;
esac

2 - Save as 010_unmount_SD.sh in your Home folder

3 - Open the Terminal (under Accessories)

4 - Use the following command to copy the file to the correct location (you will be prompted for the Admin password when you hit Enter):

sudo cp 010_unmount_SD.sh /usr/lib/pm-utils/sleep.d/010_unmount_SD.sh

5 - Set the proper permissions with this command (you will again be prompted for the Admin password):

sudo chmod 755 /usr/lib/pm-utils/sleep.d/010_unmount_SD.sh

Just as an aside, I found the rest of the information on that page to be unnecessary as my Video already looks great and power management seems to be functioning as expected. I suspect those fixes were baked into the distro for 9.10.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.