Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a Windows 7 64 bit box, whenever I try to access a server using file share, it tries to connect to port 80 http on the place of 445. I observed that using WireShark. Telnet to 445 works.

I have scanned the machine using Malware bytes, Symantec and MS Live Essentials. I don't want to recreate the whole machine again. How can I fix the ports?

share|improve this question

migrated from serverfault.com Nov 30 '11 at 12:22

This question came from our site for professional system and network administrators.

1 Answer 1

Does it do this when you try to access the share using the unc name (eg click on Start and then type either \ServerName or \serverName\shareName)

On my system, when I double click on Computer and then select Network on the left hand panel, I see a list of all my networked devices. For one of these computers it shows up twice. Once under the list of computers and then again under 'Other Devices'. The name on both devices is the same (ie the server name). The first icon will access the file share as normal, whereas the second is some sort of UPNP detection and displays a webpage which tells me a bit about the device and also gives me a link to download some software to backup my machine to the server.

Is it possible you are trying to access the server via some icon like this? If it is, then when you right click on the icon. I think you will get a 'View Device Webpage' option on the menu, rather than the normal 'Open'.

share|improve this answer
    
It does this, when I use windows run prompt . nothing special . no icon –  Mohit Dec 2 '11 at 4:04
    
Sounds like it is trying to connect using WebDav or the WebClient networking provider. Is your WebClient service running on your machine and does it make any difference it is is stopped? Also check that Netbios is not disabled on your Tcp/Ip settings. Finally check your registry value HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\NetworkProvider\Order. On mine it is RDPNP,LanmanWorkstation,webclient,LMIRfsClientNP, but I think you need to make sure that LanmanWorkstation is before webclient. –  sgmoore Dec 2 '11 at 9:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.