Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

These are the problems I am encountering.

  • XP can access Windows 7, not the other way around (which is fine, because I don't need it the other way currently)

  • File transfer is too slow like 0.031 MB/s even though netperf and netCPS list around 8-9 MB/s.

I disabled firewall on both computers. Both are same workgroup. I left homegroup on Windows 7. Windows 7 sees the connection as unidentified network.

10.1.1.2 (XP) and 10.1.1.1 (Windows 7) Subnet mask 255.255.255.0 Default gateway and DNS are empty for both of them.

Both computer are connected to internet using wireless (using home network), and both of them are connected to each other using wire!

If anybody has any pointers, do let me know. I have no problem doing such setup with both computers being Windows 7. This time one of them is XP though, and that seems to be the problem.

share|improve this question
    
I'm confused. Your question title says "using cable" but your post says they're "using wireless". Which way do you want it? If you want to use a cable, you'll need a crossover cable and static IP addressing. –  Iszi Nov 30 '11 at 14:22
    
@Iszi does it make sense now? –  TPR Nov 30 '11 at 14:31
    
possible duplicate of direct ethernet connection between two wirelessly connected win7 laptops - i'm 99% certain the answer to that question should work –  Journeyman Geek Nov 30 '11 at 14:43
1  
@Journeyman Geek but you see I'm already past that in a way. If I had to set it up between two Win 7, then it wouldn't be a problem. (I actually did do that a couple of days ago.) The problem is Win 7 and XP mix. The problem is more about the speed than the trivial things like pinging. –  TPR Nov 30 '11 at 14:59

2 Answers 2

I figured out the problem based on this thread which didn't have much to do with my own problem: http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/7aadace2-8fc0-4c7b-8ffe-76e285d02c06

On windows 7, do the following:

Control Panel --> Network and Sharing Center --> Change Adapter Settings --> right click the conection and select properties --> select Configure button --> goto Advanced tab --> look for Link Speed and Duplex --> change Auto Negotiate to 100 Mbps Full Duplex.
share|improve this answer
    
I'd forgotten about that. I'm not sure why a direct connection should require this, but I've been on some other finicky networks that do. You might want to check the same setting on your XP system. They should all be on Auto by default, and in that state they should play nice. –  Iszi Nov 30 '11 at 16:49
    
Also, take a look at this thread if you plan on doing the Speed/Duplex switching often: superuser.com/q/258746/50086 –  Iszi Nov 30 '11 at 16:58

Firstly, I'd disable the wireless for an over-the-wire file transfer. This is simply to reduce probable problem sources.

Secondly, make sure you're using a crossover cable for your connection. You can buy these from some electronics stores, or make one yourself from an existing patch cable. Seek Wikipedia for more details.

https://en.wikipedia.org/wiki/Ethernet_crossover_cable

It looks like you've got the rest of the configuration pretty much right - disabling firewalls and setting static IPs. During the file transfer, make sure the Windows 7 firewall is completely disabled for all networks (public & private). Best bet is to just shut down the service itself via services.msc. Don't forget to put your firewalls back up before you connect to the Internet again, and make sure the static IPs are on your ethernet ports and not the Wi-Fi.

Lastly, to further minimize other sources of performance interference, make sure you don't have any programs running except what is necessary for your file transfer.

share|improve this answer
    
most modern systems should not need crossover cables. they autonegotiate –  Journeyman Geek Nov 30 '11 at 14:44
    
the cable is the correct one, otherwise there wouldn't be any file transfer at all (or at least netperf etc wont report much higher speed). I did what you suggest - disabled wireless and still slow speed. –  TPR Nov 30 '11 at 14:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.