Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My company has just transitioned from an IMAP provider to a Microsoft Exchange server. As part of the transition, I moved all of my old messages from the various IMAP folders into corresponding folders on the Exchange server.

They've moved, but some of the message are showing the wrong date in the Apple Mail list views. The date is still correct in the message itself, but all of the timestamps in the list view are showing the date and time that I moved the messages, not when they were created. From some Google searches, it looks like it's the "date received" that's now wrong in the messages, and that's what the list views use.

What's weird is that it didn't do this to all of my messages - just some of them. It does look like it did it to all of the messages that were in my old IMAP "sent" folder.

How can I fix this? The messages are now in scrambled order in the list view, rather than showing in the correct (date sent/created) order - but even if I could fix the sort order, it's annoying that the timestamp has been replaced with the time it was moved into the Exchange server. I want the "received date" to go back to the date it was actually received, or if that's now impossible, I'd like to set it to the same timestamp that's in the message itself. Or, worst case, if I need to just restore all my messages from a Time Machine backup, how do I prevent this from happening the next time I try to copy these to the Exchange server?

share|improve this question
up vote 6 down vote accepted

You can sort by "Date Sent" by holding the option key when choosing the Date field in the Sort By menu. Also, selecting "Date Sent" in the View -> Message Attributes menu will cause the date sent to show up in the column view.

share|improve this answer
    
That does fix my problem of having them in the wrong order, which I appreciate, but Mail still shows the "date received" in the actual column view which makes it very difficult to find things. I'd still like a way to replace what Exchange sees as the date received with what's obviously still stored as the date sent. Thanks for this though. – Charles May 2 '12 at 0:39
    
Actually -- once I also updated the View -> Message Attributes to include "Date Sent," it changed all of the dates in the column view to the date that I want once I clicked onto a different folder and back again. I'm not sure why it shows two dates selected in the Message Attributes menu, since it's still only showing me one, but at least it's the right one now. Great! – Charles May 2 '12 at 0:43
    
This was the hint of the year for me, thx a 1000 times!!! – aorcsik Feb 8 '13 at 12:52

I also had this problem - in my case migrating a sent mail archive back to the exchange server. Again Mac mail replaced the original message date with the date of the migration. This was true both of mail on the computer used to perform the migration and on a completely different computer.

However, viewing the same message in Outlook 2016 retained all of the correct date information.

So to me it looks like an issue with Mac mail using some sort of self-written field whereas outlook reads a field embedded in the message.

share|improve this answer
    
Yeah, in the 4+ years since posting this question, I gave up on Mac Mail and switched over to using Outlook full time - not just because of this issue, but because Apple Mail was just generally flaky all the time. Outlook is rock-solid compared to Apple Mail. – Charles Feb 16 at 16:12

This happened to me going the other way, and my solution was to simply replace the "Date Received" column with "Date Sent" on that view.

share|improve this answer
    
I don't even see a way to do that in Lion Mail - the "sort by" menu on the view just has a "date" option, which is using the date received. – Charles Dec 1 '11 at 12:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.