Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have SQL Server Management Studio 2008 R2.

I have tried these:

  1. Tools->Options->Query Execution->SQL Server->General, make sure “By default, open new queries in SQLCMD mode” is unchecked

  2. Go to Tools >> Options >> Text Editor >> Transact-SQL >> General >> IntelliSense Select Auto List Members and Check Parameter Information.

  3. Restarted, repaired Visual Studio 2010

  4. Installed VS 2010 SP1

  5. Query/Intellisense Enabled selected

But still it doesn't work.

Any clue?

share|improve this question

migrated from stackoverflow.com Nov 30 '11 at 16:06

This question came from our site for professional and enthusiast programmers.

closed as off topic by studiohack Nov 30 '11 at 16:21

Questions on Super User are expected to relate to computer software or computer hardware within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

5  
Are you connecting to a SQL Server 2008+ DB when trying to use Intellisense? Even with the new SSMS, Intellisense won't work for DBs in prior versions. –  Joe Stefanelli Nov 29 '11 at 16:13
    
What does Visual Studio 2010 have to do with SQL Server Management Studio? –  Cylindric Nov 29 '11 at 16:14
    
Is it completely disabled or is it just not recognizing your stuff? Generally, you'll need to refresh (shift+ctrl+r) or restart SMSS for intellisense to pick up new objects. –  antisanity Nov 29 '11 at 16:22
    
@JoeStefanelli: I believe it's even enough if the database compatibility level is set to 2005 (90) or prior. –  marc_s Nov 29 '11 at 16:31

2 Answers 2

Visual Studio 2010 SP1 apparantly broke something:

https://connect.microsoft.com/SQLServer/feedback/details/650569/ssms-2008-r2-is-losing-intellisense-after-installing-visual-studio-2010-sp1

Do you have Service Pack 1 for SQL Server installed?

share|improve this answer

Apparently when you install VS2010 SP1 it breaks intelliSense of SQL Server 2008 R2. You will need to install either CU or SP1 for SQL Server 2008 R2 mentioned in this Support KB from MSFT.

share|improve this answer