Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Im having trouble enabling public access to my XAMMP setup. I've been looking at a few threads over at Tom's Hardware forums to resolve this issue but cant figure out we're im going wrong. Whenever I enter the public IP address I keep getting my router's login page when I enter my public IP into the browser on my PC or mob (which is on the carrier's 3G network)

I have a Belkin router port forwarding , httpd.conf and vhost per below - am I missing something???

Belkin - Port forwarding
inbound:80
type: TCP
internal private pc: 10.1.1.2
private port: 8181

-----------
httpd.conf
Listen 8181

-----------
httpd-vhosts.conf

NameVirtualHost *:8181

## Events Demo
<VirtualHost *:8181>
    ServerAdmin postmaster@eventsdemo.localhost
    DocumentRoot "L:/xampp/htdocs/eventsdemo.localhost"
    ServerName eventsdemo.localhost
    ServerAlias eventsdemo.localhost
    ErrorLog "logs/eventsdemo.localhost.log"
    CustomLog "logs/eventsdemo.localhost-access.log" combined
</VirtualHost>
share|improve this question

migrated from stackoverflow.com Nov 30 '11 at 16:09

This question came from our site for professional and enthusiast programmers.

    
Quite obviously not a programming question. Voting to move. –  unwind Nov 30 '11 at 15:54
    
#1 - Make sure your router is configured to not serve its configuration interface to the Internet. –  Iszi Nov 30 '11 at 17:07
add comment

1 Answer 1

Most modern routers have an option to put their management on your public IP address so that they can be for some reason or another managed remotely off the private LAN.

When this feature is enabled the routers web interface will be binding it's self to your public IP address and port 80. 99% of the time this will actually take precedence over any port forwarding that you have setup on the router.

Once you disable this remote management your website should be live.

Finally another thing to remember is always check from another PC/Internet connection if you can't find anything wrong with the configuration. I have seen a number of routers display management interfaces when the public IP is entered from on the private LAN, even if the port forwarding works externally.

See the below screen capture for an example of what you need to disable:

enter image description here

share|improve this answer
    
Hi iTom, remote management unchecked, port 80 forwarding to 8080 , checked "fixed" IP for my PC in the DHCP page , accessing from LAN goes straight to router still, outside of LAN i get a error "Connection reset by peer"? –  mindfriction Dec 11 '11 at 2:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.