Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I seem to have some kind of problem on my local network, for some reason /sbin/route takes a couple of seconds to run.

The first 2 lines takes approximately 0.1s before they show on the screen, but then the default route waits 2-5s before you can see it.

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.5.0     *               255.255.255.0   U     1      0        0 eth0
link-local      *               255.255.0.0     U     1000   0        0 eth0
default         192.168.5.1     0.0.0.0         UG    0      0        0 eth0

I cant really see why this occurs, since it is a small network with one router and two Ubuntu computers and a separate wlan access point (for my laptop).

The router is a Dlink DIR-100 and he takes care of the internet connection (192.168.5.1).

The computers are both running ubuntu (and gets ip-numbers from the dlink).

The wlan-router is a linksys WR54GL running tomato firmware and uses ip-number 192.168.5.2, and shares ip-number-series 192.168.6.x on the wireless side.

I can't really focus in on the problem, on what is wrong. I have looked on how the DIR-100 is configured and compared it with a friend that has a similar network setup at his house (but all looks the same).

Can somebody point me in the right direction? Why do I have that strange delay when running /sbin/route?

Thanks Albin


update: Thanks for pointing out that he tried to resolve the gateways ip number, I added that to /etc/hosts as a quick fix and it solved my problem.

This is what I added to /etc/hosts

192.168.5.1     gw      gw.bogus.net
share|improve this question
up vote 7 down vote accepted

Might be name resolv?

/sbin/route -n

will not try to lookup your ip's.

If this makes a difference, there might be a problem with how dns is setup, in your example it will try resolv 192.168.5.1 into a name using the dns server that is configured. If this dns server is your ISP's dns server it will ofc fail to find name for a computer on the local network.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .