Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows XP Home SP3 system that won't detect anything on USB. It works on Ubuntu Live (off USB), and the USB keyboard and mouse work in the BIOS. Physically speaking, I'm sure it's fine.

I installed the SMBus drivers and the USB driver from the motherboard's website, adn that went fine. If I plug anything in, it can detect the type of thing it is (i.e. keyboard, mouse, flash drive, etc) and even the name sometimes (i.e. Microsoft 5 button mouse), but won't accept any drivers. I have tried putting the Windows CD in the drive, but that didn't help.

I have scanned for viruses and CHKDSK with no issues, and ran a MemTest86 with no issues. I am limited to one PS/2 connection for inputs, so I'm using the keyboard and haven't tried WU yet.

A colleague suggested trying a new USB controller, so I put in a PCI one that only had drivers for 9x on the CD, so I assume that XP has them built in. It goes through the Found New Hardware wizard, but never actually finds drivers. I have also tried running SFC /SCANNOW and System Restore. SFC just flashes and goes away, making me believe it may be a hidden virus somewhere, but everything else seems to work, including MSE.

I have reason to believe it's just an issue with detecting hardware, since even the USB Controller card can't seem to find drivers, but it can detect WHEN a USB device is connected

Anyone else run into this, or have a suggestion short of re-installing Windows?

share|improve this question
    
I suspect the motherboard's drivers. See if you can download an older version. I've run into countless issues with a specific machine and USB devices due to using newer drivers. –  user3463 Nov 30 '11 at 23:52
    
I only saw one set of drivers for each category on the manufacturer's website –  Canadian Luke Nov 30 '11 at 23:55
    
Scanned for viruses again with MBAM. No issues found. Going to image then try repair install, unless someone has another idea –  Canadian Luke Dec 1 '11 at 0:56
    
Your phrase "won't accept any drivers" is a bit ambiguous. Can you describe in better detail exactly what is happening when you connect a device to a USB port, screenshots of Device Manager are encouraged. –  ultrasawblade Dec 1 '11 at 1:34
    
@ultrasawblade Yellow exclamation point on each USB device, or controller device. It detects the proper name. Won't find drivers –  Canadian Luke Dec 1 '11 at 17:49

2 Answers 2

Your assumption of Windows XP having drivers for a PCI USB card is wrong - Windows XP is not likely to have built-in drivers for a PCI USB card. Try visiting the manufacturer's website of that card for XP drivers (I can't imagine such a card with 9x only drivers but I suppose it is possible), or try to install the 9x drivers (if they are "WDM" drivers they will work, how well they will work is another matter)

SMBus drivers would not have anything to do with USB, they would affect things like onboard temperature sensors. USB would work over the PCI bus.

USB functionality on most motherboards these days is part of the chipset. So check that you are using the latest and most current chipset drivers.

share|improve this answer
    
The driver CD only has 9x drivers, and is supposed to be PnP for 2000 and higher. It doesn't accept the 9x drivers –  Canadian Luke Dec 1 '11 at 17:50
    
What's the make/model of the PCI card? –  ultrasawblade Dec 2 '11 at 1:42
    
VIA USB Controller card –  Canadian Luke Dec 6 '11 at 22:06
up vote 0 down vote accepted

A repair install fixed this issue. As for the USB card, it was a VIA brand USB controller.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.