Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've set nobackup and nowritebackup per this question - VIM destroys symbolic links under Windows

However, whenever I modify the file via the link, the target file is set to read-only.

How can I prevent the link target from becoming read-only?

share|improve this question
    
Do symbolic links on Windows have an extension? –  Dorian Patterson Apr 18 '12 at 1:48
    
Is this symbolic link pointing to a file on a windows share? or an NFS-connected drive? Are the files linked to local files (same disk essentially)? –  lornix Jun 30 '12 at 20:03

1 Answer 1

This seems like a bug in VIM incorrectly interpreting file-attributes on Windows.

The bug is described in 'backupcopy' and Windows Vista symbolic links, where a patch was developed to solve the problem.

I believe you will just have to wait until that patch finds its way to the release. Your other options are to download the latest VIM patch (if later than your version) or to compile your own, and if the bug is still not fixed report it again to the VIM developers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.