Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a D-link DIR-524 802.11n router. My PC is having 802.11a/b/g. The issues is that I'm unable to connect to the router when 802.11n is turned on. As soon as I disable 802.11n feature. I can connect to the router!!

Is there any was I can connect with my PC with 802.11n turned on??

EDIT: A picture of the web interface of router.. enter image description here

share|improve this question
    
What model is the router - doesn't it have a mixed (g and n) mode? –  Paul Dec 1 '11 at 22:46
    
it only gives me 2 option for 802.11n namely, 1. Auto and 2. Off..I will post the configuration page later.... –  Vineet Menon Dec 2 '11 at 6:38
    
Check with the manufacturer of your router to see if there is a firmware update for your device, it key be that an update could add a dual mode functionality. –  Mokubai Dec 2 '11 at 7:34
    
i called the customer care of D-link, but they are more lame than I am.. :P. Says the router by default supports g/n dual mode. If that's the case, then why am I not able to connect!!! –  Vineet Menon Dec 2 '11 at 10:38
    
Can you post a picture of the Advanced tab? I am looking for an option that my effect connectivity but I cannot find it on this page. –  Ali May 19 '12 at 4:37

1 Answer 1

One difference might be the 5 GHz mode which is exclusive to n and a modes. For n, this is optional, but you can force it on your router or your network interface.

Ive checked the data sheet, there is no 5GHz mode. And your computer's network can only do 2.4GHz, so that should match.

I see no reason why you should turn the n mode on, it won't bring anything special in your case.

share|improve this answer
    
didn't I mention my network card is 802.11 a/b/g. –  Vineet Menon Dec 2 '11 at 18:57
    
I live with my roommates and all of them have a n network card, which essentially make me force its use, since they will have higher data rates... –  Vineet Menon Dec 2 '11 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.