Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Apologies if this would be better on ServerFault, but I need to view logged on sessions on a remote computer with two concurrent RDP sessions.

Ideally the session would be available to connect to, as soon as either or both users were logged on, preferably without them having to take any action.

I've had a look at UltraVNC, but I can't see how to run two sessions (effectively 2 servers).


Edit: apologies - Yes, Windows. Server 2008 R2 to be specific.

share|improve this question
OS would be useful. Your best bet if this is windows would be connect to the console session and use session shadowing on both rpd sessions. – Not Kyle stop stalking me Dec 1 '11 at 15:11
@Kyle: OP mentions 2 concurrent RDP sessions -- Windows would be a pretty good first guess. Are there any RDP server implementations for other OSes? You should post that as an answer, since it's the best way. VNC sends the state of the console over the network; I don't think there's a way to make VNC do what the OP wants with remote RDP sessions. – afrazier Dec 1 '11 at 16:14

Use VNC to connect to the console session (I believe it does this by default already). Then use session shadowing to pull up both RDP sessions on the console that you are currently using VNC to connect to. This will allow you to see both sessions at the same time.


Setting this up is fairly easy:

  • First go to a domain control and click properties on the user(s) who's session you want to shadow.
  • Navigate to the Remote Control tab of properties and turn it on (which it will be by default). At this point you have to decide if you want them to grant you permission to do this or if you want to do it silently.
  • Then connect to the console session or another RDP session on the terminal server, open up task manager and go to the users tab. You can now right click the user you want to shadow and click connect to view their session.
share|improve this answer
Ok, I've set the user properties, but if I log on and go to task manager, right click on the user, and click Connect, it asks me for the user's password and then logs him out, and logs me on locally as him. The server isn't actually set up as a terminal server, so I'm limited to the two connections RDP allows. Is that relevant to why what I'm seeing is different from what you say? – ChrisA Dec 1 '11 at 18:52
That would be your problem... Without the terminal services/remote desktop role it will not function properly. – Not Kyle stop stalking me Dec 1 '11 at 20:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.