Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Apache 2.2 along with Windows 7. I just need to enable MySQL extension to work. Its okay when I'm using windows binary (.msi). But when I'm trying with .ZIP file, MySQL extension is not working. I have un-commented the extension in php.ini. But the error still presists.

Would anyone have suggestions for how to fix that?

share|improve this question
2  
What error? (And why are you using mysql anyway? It's been deprecated in favor of mysqli and pdo_mysql for years) –  Billy ONeal Dec 1 '11 at 16:30
    
Did you check that the path of the extension exists? maybe you enabled it but the .dll is missing. –  SeRPRo Dec 1 '11 at 16:31
    
Do a phpinfo() to make sure you've edited the correct php.ini –  Mark Baker Dec 1 '11 at 16:34
    
I'm trying to install wordpress. so that its needed to enable MySQL extension. @BillyONeal –  Zareef Hasan Dec 1 '11 at 16:38
    
Yup, i did called phpinfo() for that. The directory is C:\Program Files\PHP\php.ini @MarkBaker –  Zareef Hasan Dec 1 '11 at 16:45
show 3 more comments

migrated from stackoverflow.com Dec 1 '11 at 16:40

This question came from our site for professional and enthusiast programmers.

1 Answer

Probably your php.ini isn't configured correctly. Even if it is I have seen instances where I had to copy the .dll's to the same dir as the php.exe.

Definitely make sure that extension_dir is set correctly and that enable_dl = On in the .ini file, and use phpinfo() to check.

share|improve this answer
    
Thanks a lot @Timothy Martens, "enable_dl" was off. :) –  Zareef Hasan Dec 1 '11 at 17:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.