Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I considered posting in webapps, but since it is partly a browser issue, I chose this forum. In Firefox, I notice that when I open an existing Google doc or start a new one, I am not automatically in edit mode. In Google Chrome, I always start out in edit mode. In Firefox, the only thing to do is tab about 15 times to get there. I know this hasn't always been the case but I can't tell you when this behavior started. Is there a keyboard shortcut to jump into the editor pane? Also, in IE9, none of the keyboard shortcuts work in Google Docs. What gives?

share|improve this question
    
Even stranger, If I get to my document by hitting ' (link search mode) and then hitting enter to open that document, boom, I've got a blinking cursor ready to edit my doc. If I get to my document by using g-l (the google keystroke for go to list) and then navigate to my document with jjjjj... and then hit "x" and then enter, I get my document opened, but without the blinking cursor, then I have to hit "Tab" 9 times as Frank says. So, I guess I answered this myself with "In Firefox, use link search mode to open a doc" –  mcgyver5 Dec 2 '11 at 18:46

3 Answers 3

As I wrote in comment, I found that if I get to my document by hitting ' (link search mode) and then hitting enter to open that document, boom, I've got a blinking cursor ready to edit my doc. If I get to my document by using g-l (the google keystroke for go to list) and then navigate to my document with jjjjj... and then hit "x" and then enter, I get my document opened, but without the blinking cursor, then I have to hit "Tab" 9 times as Frank says. Technically, this is the answer I was searching for. Thanks for the help.

share|improve this answer

I can repro it with Firefox 8.0.1 on Mac OS X 10.6. It looks like that it may be a bug with focusing in Google Docs and/or Firefox. It's interesting that when you start with an empty cookie jar (such as Firefox's private browsing), the new document is created in a the "ready to edit" mode. In the second and subsequent visits to docs.google.com, the problem appears. It's kind of frustrating to the user, but to "enable" editing is just a mouse click away. I also found that typing "Tab" key 9 times will get you into the "real" edit mode.

share|improve this answer
    
Thanks for the confirmation. As I wrote in comment, I found that using link search mode (using the ' key) in Firefox opens the document in a way I want. Still a mystery why there are two ways to open a document. –  mcgyver5 Dec 2 '11 at 18:48

Google has made it so that a lot of the features inside of Google docs only work in Google chrome (or another HTML5 compatible browser however they may do a user-agent check have not confirmed this yet.) this happened when they changed the UI for Google Docs.

Plugins may also be interfering with some of the JavaScript that they are using. One plugin comes to mind is Noscript. You may also want to try clearing the temporary internet files in Firefox and IE.

share|improve this answer
    
yes, I have noscript, but I've been using it for years now and have scripts from google domain allowed. I really can't accept that Google has disabled features for other browsers. –  mcgyver5 Dec 2 '11 at 15:17
1  
It is not so much disabled but not implemented (Due to they use HTML5). I have run Google docs on backtrack that is a Firefox instance with Noscript Globally allowed all scripting and I could not do a lot of things. Worked on another Firefox with noscript same version just fine. Try uninstalling noscript to see if it resolves the issue. –  anzenketh Dec 2 '11 at 15:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.