Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
What limits Wifi Speed

I own a Toshiba Satellite A660-11M which has a built-in Broadcom 802.11n adapter. Just recently I bought a Wireless-N 300Mbps Access Point, specifically this one. I followed the manual on setting it up, and it is currently running at most of its default-settings:

  • Static IP
  • Working mode: Access Point
  • Security: WPA-PSK/WPA2-PSK
  • Channel Width: Auto
  • "Frequency Band": 20/40MHz

Essentially, my issue is that Windows 7 x64 Ultimate is only detecting 65.0Mbps. From a 100Mbps broadband-connection (as stated by my ISP, although I never even expected the full potential), sites such as return barely ~30Mbps. That said, I did read this question, but I am hoping that my MIMO-capable AP does make a difference from that other question.

Finally, I have tried swapping the channels (e.g. used inSSIDer to see which channels were the closest, and based on that, set my AP to 8 which wasn't used anywhere else); I also tried setting my "frequency band" (not sure how it's defined) to 40MHz only, but I only see 20/40MHz and 20MHz-only options. After reading a bit more, I also tried setting my AP to 5GHz, as it was recommended by several users, but ran out of luck as my AP doesn't offer that (or at least I was unable to find it).

I would greatly appreciate a solution or a solid answer - I would like to know that I have tried everything that is possible, and that my real issue is a matter of hardware, i.e. my adapter.

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, Dave M, soandos, ChrisF, studiohack Dec 8 '11 at 16:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Firstly, thanks for such a detailed question... It really helps us help you... – wizlog Dec 1 '11 at 20:37
@techie007 I strongly DISagree with the suggestion that this is an exact duplicate. He's having a specific interoperability problem between one AP chipset and one client chipset. The solution to his problem is not going to be the same as the solution to the other problems you suggested. – Spiff Dec 1 '11 at 22:31
@cr0z3r Please update the Question with the details of your Broadcom Wi-Fi adaptor. That Toshiba store link didn't work because your store session had timed out. I checked Toshiba's site for that model Satellite and it didn't list any of the important specs of the wireless card. – Spiff Dec 1 '11 at 22:39
@Spiff I have tried searching for more details and specifications regarding my adapter, but I didn't find much. Is there any website/database you would recommend me searching at? In any case, I am pasting the Hardware IDs of my adapter, which I think should be useful: PCI\VEN_14E4&DEV_4727&SUBSYS_7175144F&REV_01 - PCI\VEN_14E4&DEV_4727&SUBSYS_7175144F - PCI\VEN_14E4&DEV_4727&CC_028000 - PCI\VEN_14E4&DEV_4727&CC_0280 - – cr0z3r Dec 1 '11 at 22:53
up vote 5 down vote accepted

It could well be that you have a cheap HT20 (20MHz channels only), single-stream (non-MIMO, "N in name only") Broadcom card in your Satellite. For example the Broadcom 4329 chip (which was designed for smartphones, not really laptops), probably fits this description.

65mbps is a magic number that makes me suspect you're in this situation. If you have a client card that can only do 20MHz channels, single-stream, and long guard intervals, then 65 megabits per second is the highest signaling rate you can get. With short guard intervals, you can get 72.2 mbps signaling.

The rule of thumb is that TCP throughputs over Wi-Fi are about 50-60% of your signaling rate, so if you really have that limited of a card, you should expect that your highest TCP throughput under good conditions (strong signal, no noise) will be 30-40 megabits per second (that is, 3.6 to 4.8 MebiBytes per second).

Update: Yep, PCI Vendor ID 14e4 is Broadcom, and Device ID 4727 is their 4313 chip, which I have verified (via Broadcom's website) is single-stream only. I can't find any information about whether it is 40MHz-capable, but since they don't seem eager to mention it in their documentation or press releases, I suspect it might not be.

The presence of a driver option to turn on and off the "40MHz intolerant" bit is not an indication of whether or not the card supports 40MHz operation. Setting the intolerant bit is a signal to 40MHz-capable devices around you that you don't want them to ever send 40MHz-wide transmissions even if they can, not because you can't receive it (that's negotiated separately) but because you have something else running in 2.4GHz that can't tolerate band-hogging 40MHz transmissions. The most common example is if you have Bluetooth running. 40MHz Wi-Fi transmissions take up so wide a swath of the 2.4GHz ISM band that they don't leave enough room for Bluetooth devices to have enough channels to hop to. Some fully 40MHz-capable Wi-Fi-Bluetooth combo cards will intentionally choose to limit their Wi-Fi usage in 2.4GHz to 20MHz operation, and automatically set the Wi-Fi "40MHz intolerant" bit, whenever the integrated Bluetooth radio is enabled.

share|improve this answer
Spiff, thank you so much again. There are a few things I would like point out, though, which might contradict your assumptions. First, under my adapter's properties (via Device Manager), I have an option called "40MHz intolerant". If such option exists, it must mean that the adapter does tolerate 40MHz channels, right? Furthermore, I have also started to understand that this 65 is a magic-number, which however did get up to 72. Now I have read that this has something to do with long and short "signals" - but either way it might mean something. – cr0z3r Dec 1 '11 at 23:06
@cr0z3r Okay, I've updated my Answer based on the additional info you've provided. The short answer is that I'm even more convinced you're getting the best you can get out of that severely limited Broadcom card. – Spiff Dec 1 '11 at 23:26
+1 for another crazy-good Wifi answer. – Ƭᴇcʜιᴇ007 Dec 2 '11 at 0:56
Oh damn - then I guess the only other thing left for me would be to update/get a new network adapter. I am soon building a custom rig either way, so I will then take the opportunity to get something compatible. Also, I have access to an iMac which stands 2-3 meters away from the AP, which I would like to test the speeds with. I will let you know what comes up. Thank you! – cr0z3r Dec 2 '11 at 15:14

Your distance from the router will affect your speed. ("The performance of a WiFi wireless network connection depends in part on signal strength.") Also depending on how many other users are using the router at the same time may affect your speed.

share|improve this answer
Hey, thanks! However, I tested all of this with my laptop literally next to the AP, and the AP next to the modem (although that shouldn't matter, as they're connected via an Ethernet cable). So all of these elements were in a range of, say, 40 centimeters. Furthermore, I was/am the only one connected to this AP. – cr0z3r Dec 1 '11 at 22:43

Wireless networking performance can be a tricky thing to test. There can be hundreds of variables that will cause loss of performance and prevent you from getting what the advertised speed is. That's all before you leave the house. Once you pass traffic to an ISP, you loose the ability to predict what performance you will get.

Here is a testing method that you can use to determine where the "bottle-neck" is. i.e. what is making it slow.

  1. Get a performance baseline. Hook a computer directly into the ISP "modem" using a network cable and run a few speed tests. If possible verify with a second computer to make sure the computer itself is not causing the problem. This is the best possible speed you can get.
  2. Add in your home networking equipment. Plug in your wired network equipment and perform the same test. See if there is any change to the speed.
  3. Attempt a wireless connection with the laptop next to the access point. Hook in the AP and attempt the test again with the computer right next to it. See if there is any change.
  4. If the laptop will be setup in another room. Pick up the laptop and run speed tests at various places in your house. You will eventually find where the signal is best. It may not be at the original location.
  5. (Optional) If possible, switch out wireless equipment with different makes/models and see if it makes a difference. You could just have slow hardware.

I'm guessing the ISP speed will be a lot slower than what they advertise and that will be a bulk of the performance loss. When you switch to wireless mode, I can see that drop even further due to interference. Areas with many other wireless devices owned by others can drop your signal strength.

Hope this helps.

share|improve this answer
I does indeed help a lot, thank you. I will follow and try all of those steps, although some of them I have already - unintentionally- done. Thank you! – cr0z3r Dec 2 '11 at 15:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.