Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My operating system is in English.

I have two keyboards: Spanish and Japanese. I speak Spanish natively, and I'm learning Japanese, but to write in English I just use the Spanish keyboard.

The problem is that in the language bar I see three keyboard layouts, and so pressing Alt+Shift changes the languages between those three: Spanish, Japanese and English.

Is there any way to disable this? Or am I doomed because I use the OS in English?

Here is an image explaining the situation:

enter image description here

share|improve this question

2 Answers 2

Simply add it in Text services and input languages, apply the changes and then remove it again will make it disappear from the language bar.

share|improve this answer
    
I have same problem and this workaround doesn't solvet this issue. –  herry Oct 24 at 5:41

In order to remove English from the language bar, you need to do the following:

  1. Open Control Panel and under the heading Clock, Language, and Region, select Change keyboards or other input methods.
  2. On the Keyboards and Languages tab, click Change keyboards....
  3. On the General tab, select the language you wish to remove and click Remove.
  4. (optional) If you want to change the keyboard shortcut used to swap between languages, you can do so by going to the Advanced Key Settings tab, changing the appropriate settings.
share|improve this answer
    
As I said I only have the Spanish and Japanese keyboards there, not the English keyboard, hence the problem, the English keyboard shows up in the language bar although I don't have it added as a default keyboard layout. –  Zequez Dec 2 '11 at 0:44
    
@Zequez Oh I see what you mean now. Is English showing up as the default language in the dialog box even though the keyboard layout isn't there? If so, is it possible to change it to Spanish in the dropdown list? Edit: Here's an image of the options I'm talking about: i.stack.imgur.com/NSSEL.gif –  John H Dec 2 '11 at 1:47
    
No, what I mean is this: dl.dropbox.com/u/3682061/i_mean_this.png –  Zequez Dec 2 '11 at 2:26
    
Alright, can you try this for me? Control Panel -> Clock, Language and Region, select Install or uninstall display languages and see if English is in the list. –  John H Dec 2 '11 at 2:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.