Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The key binding for isearch-forward-regexp is C-M-s, however I cannot invoke that bindings somehow using Ctrl+Alt+s. I can do Esc then C-s to invoke it though.

Other commands with the C-M prefix works fine using Ctrl+Alt though, like C-M-w (append-next-kill), C-M-f (forward-sexp) etc

Can anybody an idea on what the problem on my system is? I am using GNU Emacs 23.3.1 on Ubuntu 11.10.

share|improve this question
    
What does Emacs tell you is bound to when you type: C-h k C-M-s? –  Trey Jackson Dec 5 '11 at 20:54
    
It doesn't respond, I still have the "Describe key:" prompt in the minibuffer after pressing Ctrl+Alt+s. I can see what Ctrl+Alt+w is bound to though. –  loudandclear Dec 6 '11 at 6:40
    
That leads me to believe that the window system is not passing that event to Emacs. I'd ask the same question on askubuntu.com –  Trey Jackson Dec 6 '11 at 16:23
    
Did you ever figure this out? I'm having the same problem, and google is failing me... –  krupan Apr 6 '12 at 23:10
    
As Trey Jackson indicated, C-M-s was a keyboard shortcut for my operating system and everything worked well after disabling it. –  loudandclear Apr 8 '12 at 18:27
add comment

1 Answer 1

up vote 2 down vote accepted

On Ubuntu 11.10, and on Ubuntu 12.04, the "toggle shaded state" keyboard shortcut is assigned to Ctrl+Alt+S by default. Changing it to something else enables the usage of that keybinding inside Emacs.

share|improve this answer
    
Where can I change the binding? –  User Jan 29 '13 at 22:55
1  
nvm in 12.10 found it under Settings->Keyboard->Shortcuts –  User Jan 29 '13 at 22:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.