Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm experiencing DNS issues while trying to host my own DNS & webserver on my home LAN. Basically, I see proper DNS resolve on the DNS server, but not anywhere else on the LAN or public WWW.

I'll admit I've never installed BIND before, but have administered zone files, in any event please make no assumptions.

I have a LAMP server up and running on my home LAN. It's running Ubuntu 10.04 LTS.

Given that I cannot obtain a static IP from my ISP, and also don't want to pay a domain provider for DNS management, I've decided to try and install BIND9 on the server too, so that I can manage DNS myself.

I've followed the Primary Master section of this tutorial. Note: I did not add reverse DNS, as I did not think this was necessary to resolve an IP from a domain. I will do this later, once everything else is working.

As I said, I am new, and do not really know where to begin.

Here are a few tidbits:

dig @localhost carylson.com

; <<>> DiG 9.7.0-P1 <<>> @localhost carylson.com
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20700
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;carylson.com.          IN  A

;; ANSWER SECTION:
carylson.com.       300 IN  A   127.0.0.1

;; AUTHORITY SECTION:
carylson.com.       300 IN  NS  ns0.carylson.com.
carylson.com.       300 IN  NS  ns1.carylson.com.

;; ADDITIONAL SECTION:
ns0.carylson.com.   300 IN  A   127.0.0.1
ns1.carylson.com.   300 IN  A   127.0.0.1

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Nov 29 20:58:35 2011
;; MSG SIZE  rcvd: 114

dig @8.8.8.8 carylson.com GOOGLE NAMESERVERS

; <<>> DiG 9.7.0-P1 <<>> @8.8.8.8 carylson.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 60779
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;carylson.com.          IN  A

;; Query time: 1052 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Tue Nov 29 21:00:28 2011
;; MSG SIZE  rcvd: 30

Any pointers are appreciated.

share|improve this question

migrated from stackoverflow.com Dec 2 '11 at 12:32

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer

You need to publish your name server IP with your registrar.

[ ~]$ whois carylson.com  | tail
Domain servers in listed order:
      NS.WEBS.CARYLSON.COM
      NS0.CARYLSON.COM
      NS1.CARYLSON.COM

All these are pointing to 69.204.115.89 which I guess is your home IP.

[ ~]$ host 69.204.115.89
89.115.204.69.in-addr.arpa domain name pointer cpe-69-204-115-89.buffalo.res.rr.com.

If that is true, then you need to check two things:

  1. See if you've punched a hole in your incoming modem to allow DNS traffic to reach your server
  2. See if there is an ACL in the bind config that is blocking queries. This is most likely the problem since you say you can't query from the LAN either. If you see something like:

    allow-query { 127.0.0.1; };
    

    in your zone or global config, change them to

    allow-query { any; };
    
share|improve this answer
    
Great, I seem to have it working now. –  carylson Dec 2 '11 at 4:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.