Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I added additional Desktops (previously known as Spaces) via Mission Control on Lion. On each additional desktop the menu bar is missing. The menu bar is only visible/accessible from the primary desktop.

What do I need to change to make the menu bar appear on all Desktop spaces?

Here's my current setup as seen through Mission Control. I have 6 Desktops, but the menu bar is only available on Desktop 1. All other desktops have no menu bar, and thus running an application on Desktops 2-6 is more or less useless right now. I want these Desktops to work like the Spaces in Snow Leopard.

enter image description here

share|improve this question
    
Are you sure these are additional desktops, and not full-screen applications? The latter contain a hidden menu bar only. –  Daniel Beck Dec 2 '11 at 12:48
1  
Could yu maybe upload a screenshot otherwise? –  Daniel Beck Dec 2 '11 at 12:54
    
This feature is unavaiable in Lion (or any OSX for that matter). An alternative solution that may partially solve your problem is this: Navigate to System Preferences/Displays then, you can click and drag the menubar from one screen to the other in the Display window. This will effectively change your primary display to where ever you drag the menubar, but stretching or repeating the menu bar acrross multiple displays isnt possible. –  user107856 Dec 2 '11 at 13:57
    
I don't think this is the user's issue. This isn't about external additional screens (as in hardware), but virtual desktops via Mission Control (formerly "Spaces") –  Daniel Beck Dec 2 '11 at 14:41
    
My question is about showing the menu bar on every virtual desktop (spaces), it isn't about spanning multiple monitors. –  LearnCocos2D Dec 2 '11 at 14:54
show 3 more comments

1 Answer

up vote 1 down vote accepted

Seems to have been an intermittent (?) bug. I simply removed all desktops I had created, and then re-added new desktops. Every new one I added using the exact same method as before (click on the + in Mission Control's upper right corner) now has the menu bar.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.