Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on a Mac and use mainly Firefox 8, but the problem that I'll describe happens with Chrome and Safari as well.

Basically, I can play most Flash content, including ads, games and videos, but there are some specific videos that do not play at all (the flash portion of the page stays black). For an example of such video, see this page (brazilian news site).

I have the latest version of Flash player and I was able to play the video using the URL of the player concatenated with the flashVars that I got from the source code os the page.

Any ideas on what's causing this? Thanks.

share|improve this question
add comment

1 Answer

It sounds like some sort of ad-blocker is interfering (false-positive).

  • Are you using an ad-blocking browser-extension? > If so, try adding the site to the exceptions.

  • Are you using the HOSTS file for ad-blocking? > If so, you’ll need to figure out what domain(s) to remove from it.

  • Are you using some other security software with ad-blocking features? > If so, try disabling it.

share|improve this answer
    
Thanks for answering. I already tested with a clean browser (no blockers of any kind). As I said, I can see ads normally in the site, just the videos that won't play automatically. I've posted in the Adobe Forum. Sadly there was no answer. I'm giving up on this :( –  Vinicius Pinto Dec 10 '11 at 16:33
    
Like I said, it might not be the browser; it could be getting blocked in the HOSTS file or other security software (eg firewall, anti-virus, router, etc.) You have to understand that providers and CDNs change their hosts and IPs often, so what was blocked or not blocked last week may end up changing this week, so you (or the software) cannot simply set one set of rules and leave it for all time; they have to be updated regularly. –  Synetech Dec 10 '11 at 22:25
    
Thanks again. There's nothing blocking the content. If I go to the source code of the page containing the Flash video, copy the URL of the video and concatenate the flashVars attribute, the video plays fine. –  Vinicius Pinto Dec 11 '11 at 1:08
    
Ah, okay, then it is JavaScript that is getting tripped up. Try a different browser to verify. –  Synetech Dec 11 '11 at 18:41
    
Ah, okay; that is important information. It is probably JavaScript that is getting tripped up. Try a different browser to verify. –  Synetech Dec 11 '11 at 18:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.