Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently I started having problems with Media Player Classic Homecinema. As far as I know, I didn't install any updates (or any new software actually). Also, I'm using default Windows 7 RC codecs; I didn't need to install any codec packs.

What happens is that when MPC is started, it opens fullscreen on secondary monitor. I guess that it opens some sort of error dialog, but I can't read it because MPC window is open above it. When I dismiss dialog (ESC or Enter) the movie starts to play, however no MPC GUI elements show (though I can click on them). When focus is moved to another app, MPC window resizes and becomes unresponsive. During the process, some window elements in other programs become garbled (but refreshing the window fixes that).

This happens on different video types (avi, wmv, flv) and affects both 32bit and 64bit MPC versions. At the same time, Windows Media Player works flawlessly.

I reinstalled MPC and replaced it with a newer version, with no effect whatsoever.

The only thing I can think of is to reinstall codecs, but how do you do that in Windows 7? Any ideas are welcome.

P.S. I'm not interested in other players.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Have you tried completely uninstalling and reinstalling MPC Homecinema? What I mean is, can you be 100% sure you have fully cleared / reset configuration options for it?

Could be a borked configuration option for the app, particularly if it was working before.

share|improve this answer
    
It could also be a compatibility issue. Maybe starting Homecinema in Vista compatibility mode might help troubleshoot the problem. Or running it as administrator, it may need rights somewhere. –  Diago Sep 5 '09 at 21:18
1  
Jeff, you gave me the idea; I deleted "Gabest" group of keys from registry, and reinstalled. There was also an option in installer to load previous settings; this time I made sure to have it unchecked. This fixed the problem. Thanks! :) –  Domchi Sep 5 '09 at 21:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.