Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

NOTE: I am not trying to disable UAC.

I have a Windows 7 machine where I've added one administrator account and one regular user account. When using the regular user account, a UAC dialog will show up having a password prompt when an application requires administrative privileges. Entering the administrator's password will allow the action to continue, but this is not the behavior that I require. Instead of prompting for the password, I would like the action to either silently fail (with the action logged in the system log) or show a permission denied dialog.

Is this possible? If so, how do I do it?

share|improve this question
up vote 5 down vote accepted

You can change how UAC acts in this scenario by using Security Policies:

Instructions from here:

Follow these steps to eliminate UAC prompts for standard users:

  • Click on the start menu, type "secpol.msc" and hit Enter.
  • When the "Local Security Policy" editor ("snap-in") opens, double-click on "Local Policies" -for those affecting this particular machine- and double-click on "Security Options".
  • Scroll down until you see a node labeled "User Account Control: Behavior of the Elevation Prompt for Standard Users" (careful, another policy starts with the same name, but actually affects computer administrators!) Double-click on it and the following dialog will open:

enter image description here

  • The default behavior for standard users, selected in the dropdown menu pictured above, is "Prompt for credentials": whenever elevated privileges are required, they'll need to select an administrator and enter its password in a UAC prompt to proceed with the action.
  • Click on the dropdown, and select the "Automatically deny elevation requests" option instead; click "OK" to apply the new setting: from this point on, standard users won't event get a UAC prompt when they attempt any task that needs administrative permissions.

See the link for extended information.

share|improve this answer
    
Ah, that's it! I figured it could be done in mmc somehow. Thanks a million. – achristi Dec 2 '11 at 19:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .